tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rui Monteiro <rmonte...@mecatena.com>
Subject [Fwd: [Fwd: Re: [Fwd: Can't run jsp pages on tomcat 6.0.10]]]
Date Tue, 10 Apr 2007 03:07:45 GMT
I put the same instalation (the same jars on lib) on a tomcat6.0.10 
installed in my windows xp machine and everything goes fine. The problem 
only occurs on the Centos 4 machine and only for jsp. If anyone knows 
the inner subtleties of jasper jsp compiler tell me what could be going 
wrong.



-------- Mensaje original --------

Ok that wasn't exactly true. The examples which work ok are only the 
servlets examples (and by the way a pure zk application uses only 
servlets thats why the other app goes ok too). The jsp examples don't go 
ok. In fact they present the same error as the empty webapp. So I am 
left with a problem with the jsp servlet of my tomcat 6.0.10 
installation. I will have  to check it out all libraries added to the 
tomcat lib. If any one can give me a clue this is the list of jars 
inside the tomcat/lib:

activation.jar               jasper-jdt.jar
annotations-api.jar          jasper-runtime.jar
ant.jar                      jcommon.jar
ant-launcher.jar             jfreechart.jar
antlr-2.7.6rc1.jar           jmx.jar
asm-attrs.jar                jruby.jar
asm.jar                      js.jar
bsh.jar                      json_simple.jar
catalina-ant.jar             jsp-api.jar
catalina-ha.jar              jta.jar
catalina.jar                 log4j-1.2.11.jar
catalina-tribes.jar          mail.jar
cglib-2.1.3.jar              mysql-connector-java-3.1.12-bin.jar
commons-beanutils.jar        naming-factory-dbcp.jar
commons-collections-3.1.jar  naming-factory.jar
commons-dbcp-1.2.1.jar       naming-resources.jar
commons-digester.jar         servlet-api.jar
commons-el.jar               timelinez.jar
commons-fileupload.jar       tomcat-coyote.jar
commons-io.jar               tomcat-dbcp.jar
commons-logging-1.0.4.jar    tomcat-i18n-es.jar
commons-pool-1.2.jar         tomcat-i18n-fr.jar
dojoz.jar                    tomcat-i18n-ja.jar
dom4j-1.6.1.jar              tools.jar
el-api.jar                   xalan.jar
fckez.jar                    xercesImpl.jar
gmapsz.jar                   xml-apis.jar
groovy.jar                   zcommon.jar
hibernate2.jar               zhtml.jar
jasper-compiler.jar          zk.jar
jasper-compiler-jdt.jar      zkplus.jar
jasper-el.jar                zul.jar
jasper.jar                   zweb.jar

Please give me a clue. As i said it's a generic problem when compiling jsp.

-------- Mensaje original --------

Right now I get the problem in an empty webapp! A folder with a jsp 
inside.... an empty jsp!!!
The funny thing is that I have another ZK aplication (it was supposed to 
be more complicated than a webapp that it is an empy jsp....at least 
from the deployment point of view ;) ) that runs fine. And the examples 
webapp demo goes fine as well... the error is the same as i posted 
already. The environment either: Centos 4; tomcat 6.0.10; jdk 1.6; and 
the same thing : if i make the empty jsp an empty html, everything is 
ok... but please don't ask me to make a war of an empty file...


*exception*

javax.servlet.ServletException: Servlet.init() para servlet jsp lanzó excepción
	org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:104)
	org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:216)
	org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:844)
	org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:634)
	org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:445)
	java.lang.Thread.run(Thread.java:619)

*root cause*

java.lang.NoSuchFieldError: IS_SECURITY_ENABLED
	org.apache.jasper.compiler.JspRuntimeContext.<init>(JspRuntimeContext.java:136)
	org.apache.jasper.servlet.JspServlet.init(JspServlet.java:101)
	org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:104)
	org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:216)
	org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:844)
	org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:634)
	org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:445)
	java.lang.Thread.run(Thread.java:619)




Hassan Schroeder escribió:
> On 4/9/07, Rui Monteiro <rmonteiro@mecatena.com> wrote:
>> Nobody says nothing so i admit it it's something new as i feared. And
>> probably nobody is using tomcat 6 (wise people).
>
> Hardly :-)
>
>> Am i the only one who thinks the migration between tomcat versions is
>> too much of a headache?
>
> Possibly -- I switched from 5.5.x/Java 5 to 6.0.x/Java 6 by changing the
> batch file I use to set CATALINA_HOME and JAVA_HOME, and none of my
> apps complained in the slightest.
>
> Can you post a simple WAR file showing the problem you're seeing?
>


-- 





-- 



---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message