tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Frank W. Zammetti" <>
Subject Filter class not found problem
Date Mon, 02 Apr 2007 05:11:05 GMT
Hey folks... I'm having a real pain of a problem here... vital stats:

JRE 1.6.0-b105 (JDK 6)
Tomcat 6.0.10

I have a filter that compiles fine but will not initialize... error that 
appears on Tomcat startup:

Apr 2, 2007 1:04:38 AM org.apache.catalina.core.StandardContext filterStart
SEVERE: Exception starting filter MasterControlFilter
java.lang.NoClassDefFoundError: javax/servlet/Filter
	at java.lang.ClassLoader.defineClass1(Native Method)
	at java.lang.ClassLoader.defineClass(
...and so on...

The filter is contained within a JAR in my webapp's WEB-INF/lib 
directory.  I've verified the filter is in the correct package, and that 
web.xml specifies the correct class name.

I've spent about an hour Googling, and I've found numerous references to 
seemingly similar problems, but no answers... I've verified that there 
is no other servlet-api.jar floating around... I did notice a number of 
places that said servlet-api.jar should be in CATALINA_HOME/common/lib, 
but it's in CATALINA_HOME/lib in my installation (that's how it came out 
of the distro)... I assume that's just some old documentation I'm 
finding, but maybe not?

For completeness, environment variables I have:

...NO classpath defined...

I don't think there's any other relevant env vars.  Can anyone point me 
in the right direction?  I'm pretty well stuck at the moment until I get 
this resolved.  Thanks!


Frank W. Zammetti
Founder and Chief Software Architect
Omnytex Technologies
AIM/Yahoo: fzammetti
Author of "Practical Ajax Projects With Java Technology"
  (2006, Apress, ISBN 1-59059-695-1)
Java Web Parts -
  Supplying the wheel, so you don't have to reinvent it!

To start a new topic, e-mail:
To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message