tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Fargusson.Alan" <Alan.Fargus...@ftb.ca.gov>
Subject RE: Problem with compiling tomcat native
Date Tue, 24 Apr 2007 16:14:06 GMT
This look right to me, in that /bin/sh is actually bash.  So I don't understand why it doesn't
work.  Perhaps there is some incompatibility in different versions of bash.  Is it possible
that this work in bash 2.x and not in bash 3.x?  Perhaps you can do a "bash -version" on a
system ware the configure works, and on a system ware it does not work just to see if they
use different versions of bash.

-----Original Message-----
From: Orlando Reis [mailto:reis.orlando@gmail.com]
Sent: Tuesday, April 24, 2007 8:29 AM
To: Tomcat Users List
Subject: Re: Problem with compiling tomcat native


I am almost sure you are right about the problem, it is a shell problem. I
will try having a look at this later but for now I don't have any clues to
what might be causing this, I'm going try make some debugging of the script.


vserv-deb:~# locate sh|grep bin|grep -v runner|grep -v locale|grep -v
icons|grep -v man|grep -v ice|grep -v share|grep -v jdk|grep -v apache|grep
-v ssh|grep -v sha|grep -v gnome
/bin/bash
/bin/rbash -> bash
/bin/sh -> bash
/sbin/shutdown
/usr/bin/bashbug
/usr/bin/btcflash
/usr/bin/chsh
/usr/bin/c_rehash
/usr/bin/debconf-show
/usr/bin/dpkg-shlibdeps
/usr/bin/gettext.sh
/usr/bin/instmodsh
/usr/bin/omshell
/usr/bin/rsh -> ssh
/usr/bin/showcfont
/usr/bin/showfont
/usr/bin/showkey
/usr/bin/showrgb
/usr/bin/shred
/usr/bin/tclsh
/usr/bin/tclsh8.4
/usr/bin/xrefresh
/usr/local/build/httpd-2.2.4/build/binbuild.sh
/usr/local/build/httpd-2.2.4/build/install-bindist.sh.in
/usr/sbin/add-shell
/usr/sbin/ownership
/usr/sbin/remove-shell
/var/lib/dpkg/info/binutils.shlibs
/var/lib/dpkg/info/libbind9-0.shlibs



A more verbose output of the error:

vserv-deb:/usr/local/build/tomcat-native-1.1.10-src/jni/native# ./configure
--with-java-home=$JAVA_HOME --with-apr=/usr/local/apr-httpd

checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking target system type... i686-pc-linux-gnu
checking for a BSD-compatible install... /usr/bin/install -c
checking for working mkdir -p... yes
Tomcat Native Version: 1.1.10
checking for chosen layout... tcnative
checking for APR... yes
  setting CC to "gcc"
  setting CPP to "gcc -E"
checking for a BSD-compatible install... /usr/bin/install -c
checking for JDK location (please wait)... /usr/local/java.1.6
checking Java platform... checking Java platform...
checking for sablevm... NONE
  adding "-I/usr/local/java.1.6/include" to TCNATIVE_PRIV_INCLUDES
checking os_type directory...  linux
  adding "-I/usr/local/java.1.6/include/linux" to TCNATIVE_PRIV_INCLUDES
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking for OpenSSL library... using openssl from /usr/lib and /usr/include
checking OpenSSL library version... ok
checking for OpenSSL DSA support... yes
  setting TCNATIVE_LDFLAGS to "-lssl -lcrypto"
  adding "-DHAVE_OPENSSL" to CFLAGS
  setting TCNATIVE_LIBS to ""
  setting TCNATIVE_LIBS to " /usr/local/apr-httpd/lib/libapr-1.la -lrt
-lcrypt  -lpthread -ldl"
./configure: line 4280: APR_INCLUDES: command not found
./configure: line 4281: APR_LIBS: command not found
./configure: line 4282: APR_LIB_TARGET: command not found
./configure: line 4283: APR_SO_EXT: command not found
./configure: line 4284: BASH: command not found
./configure: line 4285: BASH_ARGC: command not found
./configure: line 4286: BASH_ARGV: command not found
./configure: line 4287: BASH_LINENO: command not found
./configure: line 4288: BASH_SOURCE: command not found
./configure: line 4289: BASH_VERSINFO: command not found
./configure: line 4290: BASH_VERSION: command not found
./configure: line 4291: CC: command not found
./configure: line 4292: CFLAGS: command not found
./configure: line 4293: CPP: command not found
./configure: line 4294: DIRSTACK: command not found
./configure: line 4295: DUALCASE: command not found
./configure: line 4296: ECHO_C: command not found
./configure: line 4297: ECHO_N: command not found
./configure: line 4298: ECHO_T: command not found
./configure: line 4299: EUID: command not found
./configure: line 4300: EXEEXT: command not found
./configure: line 4301: EXTRA_OS_LINK: command not found
./configure: line 4302: GCC: command not found
./configure: line 4303: GROUPS: command not found
./configure: line 4304: HOME: command not found
./configure: line 4305: HOSTNAME: command not found
./configure: line 4306: HOSTTYPE: command not found
./configure: line 4307: IFS: command not found
./configure: line 4308: INCLUDE_OUTPUTS: command not found
./configure: line 4309: INCLUDE_RULES: command not found
./configure: line 4310: INSTALL: command not found
./configure: line 4311: INSTALL_DATA: command not found
./configure: line 4312: INSTALL_PROGRAM: command not found
./configure: line 4313: INSTALL_SCRIPT: command not found
./configure: line 4314: JAVA_HOME: command not found
./configure: line 4315: JAVA_HOME_ENV: command not found
./configure: line 4316: JAVA_INC: command not found
./configure: line 4317: JAVA_OS: command not found
./configure: line 4318: JAVA_PLATFORM: command not found
./configure: line 4319: LANG: command not found
./configure: line 4320: LANGUAGE: command not found
./configure: line 4321: LAYOUT: command not found
./configure: line 4322: LC_ADDRESS: command not found
./configure: line 4323: LC_ALL: command not found
./configure: line 4324: LC_COLLATE: command not found
./configure: line 4325: LC_CTYPE: command not found
./configure: line 4326: LC_IDENTIFICATION: command not found
./configure: line 4327: LC_MEASUREMENT: command not found
./configure: line 4328: LC_MESSAGES: command not found
./configure: line 4329: LC_MONETARY: command not found
./configure: line 4330: LC_NAME: command not found
./configure: line 4331: LC_NUMERIC: command not found
./configure: line 4332: LC_PAPER: command not found
./configure: line 4333: LC_TELEPHONE: command not found
./configure: line 4334: LC_TIME: command not found
./configure: line 4335: LIBOBJS: command not found
./configure: line 4336: LIBS: command not found
./configure: line 4337: LINENO: command not found
./configure: line 4338: LOGNAME: command not found
./configure: line 4339: LS_COLORS: command not found
./configure: line 4340: LS_OPTIONS: command not found
./configure: line 4341: MACHTYPE: command not found
./configure: line 4342: MAKEFILES: command not found
./configure: line 4343: MAKEFLAGS: command not found
./configure: line 4344: MFLAGS: command not found
./configure: line 4345: OBJEXT: command not found
./configure: line 4346: OPENSSL_WARNING: command not found
./configure: line 4347: OPTERR: command not found
./configure: line 4348: OPTIND: command not found
./configure: line 4349: OSTYPE: command not found
./configure: line 4350: PACKAGE_BUGREPORT: command not found
./configure: line 4351: PACKAGE_NAME: command not found
./configure: line 4352: PACKAGE_STRING: command not found
./configure: line 4353: PACKAGE_TARNAME: command not found
./configure: line 4354: PACKAGE_VERSION: command not found
./configure: line 4355: PATH: command not found
./configure: line 4356: PATH_SEPARATOR: command not found
./configure: line 4357: PIPESTATUS: command not found
./configure: line 4358: POSIXLY_CORRECT: command not found
./configure: line 4359: PPID: command not found
./configure: line 4360: PS1: command not found
./configure: line 4361: PS2: command not found
./configure: line 4362: PS4: command not found
./configure: line 4363: PWD: command not found
./configure: line 4364: SABLEVM: command not found
./configure: line 4365: SHELL: command not found
./configure: line 4366: SHELLOPTS: command not found
./configure: line 4367: SHLVL: command not found
./configure: line 4368: SSH_CLIENT: command not found
./configure: line 4369: SSH_CONNECTION: command not found
./configure: line 4370: SSH_TTY: command not found
./configure: line 4371: TCNATIVE_DOTTED_VERSION: command not found
./configure: line 4372: TCNATIVE_INCLUDES: command not found
./configure: line 4373: TCNATIVE_LDFLAGS: command not found
./configure: line 4374: TCNATIVE_LIBNAME: command not found
./configure: line 4375: TCNATIVE_LIBS: command not found
./configure: line 4376: TCNATIVE_LIBTOOL_VERSION: command not found
./configure: line 4377: TCNATIVE_MAJOR_VERSION: command not found
./configure: line 4378: TCNATIVE_PRIV_INCLUDES: command not found
./configure: line 4379: TCN_CONFIG_LOCATION: command not found
./configure: line 4380: TCN_OPENSSL_INC: command not found
./configure: line 4381: TCN_OPENSSL_LIBS: command not found
./configure: line 4382: TERM: command not found
./configure: line 4383: TEST_X: command not found
./configure: line 4384: UID: command not found
./configure: line 4385: USER: command not found
./configure: line 4386: USE_OPENSSL: command not found
./configure: line 4387: _: command not found
./configure: line 4388: abs_builddir: command not found
./configure: line 4389: abs_srcdir: command not found
./configure: line 4390: ac_abs_confdir: command not found
./configure: line 4391: ac_arg: command not found
./configure: line 4392: ac_aux_dir: command not found
./configure: line 4393: ac_build_alias: command not found
./configure: line 4394: ac_c_werror_flag: command not found
./configure: line 4395: ac_cache_corrupted: command not found
./configure: line 4396: ac_clean_files: command not found
./configure: line 4397: ac_clean_files_save: command not found
./configure: line 4398: ac_compile: command not found
./configure: line 4399: ac_compiler: command not found
./configure: line 4400: ac_compiler_gnu: command not found
./configure: line 4401: ac_confdir: command not found
./configure: line 4402: ac_config_commands: command not found
./configure: line 4403: ac_config_files: command not found
./configure: line 4404: ac_config_guess: command not found
./configure: line 4405: ac_config_libobj_dir: command not found



On 4/24/07, Orlando Reis <reis.orlando@gmail.com> wrote:
>
> Ok, I understand your point of view, I've checked it and /bin/sh on debian
> 4 points to /bin/bash, you might be right, question is, how do I do fix
> this.
>
> When I say you might be right is because there are other scripts in
> jni/native/build which are bourne shell scripts. Those scripts are called
> when you do a ./configure
>
> vserv-deb:/usr/local/build/tomcat-native-1.1.10-src/jni/native# ls -l
> build
> total 156
> -rw-r--r-- 1 root root 26635 2007-04-23 20:21 apr_common.m4
> -rwxr-xr-x 1  500 root  2115 2007-01-05 17:33 buildcheck.sh
> -rwxr-xr-x 1 root root 44208 2007-04-23 20:21 config.guess
> -rwxr-xr-x 1 root root 32448 2007-04-23 20:21 config.sub
> -rw-r--r-- 1 root root  6302 2007-04-23 20:21 find_apr.m4
> -rwxr-xr-x 1  500 root  1156 2007-01-05 17:33 get-version.sh
> -rwxr-xr-x 1 root root  2631 2007-04-23 20:21 install.sh
> -rw-r--r-- 1  500 root  3633 2007-01-05 21:57 lineends.pl
> -rwxr-xr-x 1  500 root   980 2007-01-05 17:33 mkdir.sh
> drwxr-xr-x 2  500 root  4096 2007-04-02 07:07 rpm
> -rw-r--r-- 1 root root  6149 2007-04-23 20:21 rules.mk
> -rw-r--r-- 1  500 root 10421 2007-04-02 05:51 tcnative.m4
>
>
> On the other hand, that already happened on debian 3.1 and I was able to
> build the hole thing on a client:
> apache(with apr and apr-util)/tomcat-native/tomcat-connector
>
> Same versions I'm trying to build now.
>
> Orlando Reis
>
> On 4/23/07, Fargusson.Alan <Alan.Fargusson@ftb.ca.gov> wrote:
> >
> > I just want to make one point clear:  Even when you are using bash, if
> > /bin/sh is linked to some other shell, or is a copy of some other shell,
> > then shell scripts may be run by that other shell, and not bash.
> >
> > I have seen problems due to the order in which packages are
> > installed.  It seems that some packages link /bin/sh to the shell contained
> > in that package, so even though bash was the default shell to start with,
> > some other shell ends up replacing it, and fails to run configure scripts.
> >
> > -----Original Message-----
> > From: Orlando Reis [mailto:reis.orlando@gmail.com]
> > Sent: Monday, April 23, 2007 12:06 PM
> > To: Tomcat Users List
> > Subject: Re: Problem with compiling tomcat native
> >
> >
> > Thanks for the reply Alan.
> >
> > I'm using bash, and have used bash in Solaris, Linux (Centos, RHE5,
> > Fedora,
> > Ubuntu).
> >
> > None of those platforms gave me a headache, only Debian 4.0, with
> > Debian 3.1I didn't have a problem.
> >
> > Orlando
> >
> > On 4/23/07, Fargusson.Alan <Alan.Fargusson@ftb.ca.gov> wrote:
> > >
> > > It may be that the configure script depends on the default shell
> > (/bin/sh)
> > > being BASH.  Does it work if you do "bash configure"?
> > >
> > > -----Original Message-----
> > > From: Orlando Reis [mailto:reis.orlando@gmail.com]
> > > Sent: Monday, April 23, 2007 4:25 AM
> > > To: users@tomcat.apache.org
> > > Subject: Problem with compiling tomcat native
> > >
> > >
> > > Hi, I'm having some trouble compiling tomcat-native-1.1.10-src, I've
> > done
> > > this before on several different platforms, but for some reason the
> > > lastest
> > > debian (4.0 etch) is giving me problems.
> > >
> > > vserv-deb:/usr/local/build/tomcat- native-1.1.10-src/jni/native# sh
> > > buildconf
> > > --with-java-home=$JAVA_HOME --with-apr=/usr/local/build/httpd-2.2.4
> > > /srclib/apr
> > >
> > > Looking for apr source in /usr/local/build/httpd-2.2.4/srclib/apr
> > > Creating configure ...
> > > Generating 'make' outputs ...
> > > rebuilding rpm spec file
> > > vserv-deb:/usr/local/build/tomcat-native-1.1.10-src/jni/native#
> > > ./configure
> > > --with-java-home=$JAVA_HOME --with-apr=/usr/local/apr-httpd
> > > --with-ssl=/usr/local/openssl
> > > checking build system type... i686-pc-linux-gnu
> > > checking host system type... i686-pc-linux-gnu
> > > checking target system type... i686-pc-linux-gnu
> > > checking for a BSD-compatible install... /usr/bin/install -c
> > > checking for working mkdir -p... yes
> > > Tomcat Native Version: 1.1.10
> > > checking for chosen layout... tcnative
> > > checking for APR... yes
> > >   setting CC to "gcc"
> > >   setting CPP to "gcc -E"
> > > checking for a BSD-compatible install... /usr/bin/install -c
> > > checking for JDK location (please wait)... /usr/local/java.1.6
> > > checking Java platform... checking Java platform...
> > > checking for sablevm... NONE
> > >   adding "-I/usr/local/java.1.6/include" to TCNATIVE_PRIV_INCLUDES
> > > checking os_type directory...  linux
> > >   adding "-I/usr/local/java.1.6/include/linux" to
> > TCNATIVE_PRIV_INCLUDES
> > > checking for gcc... gcc
> > > checking for C compiler default output file name... a.out
> > > checking whether the C compiler works... yes
> > > checking whether we are cross compiling... no
> > > checking for suffix of executables...
> > > checking for suffix of object files... o
> > > checking whether we are using the GNU C compiler... yes
> > > checking whether gcc accepts -g... yes
> > > checking for gcc option to accept ISO C89... none needed
> > > checking for OpenSSL library... using openssl from
> > /usr/local/openssl/lib
> > > and /usr/local/openssl/include
> > > checking OpenSSL library version... ok
> > > checking for OpenSSL DSA support... yes
> > >   adding "-I/usr/local/openssl/include" to TCNATIVE_PRIV_INCLUDES
> > >   setting TCNATIVE_LDFLAGS to "-L/usr/local/openssl/lib -lssl
> > -lcrypto"
> > >   adding "-DHAVE_OPENSSL" to CFLAGS
> > >   setting TCNATIVE_LIBS to ""
> > >   setting TCNATIVE_LIBS to " /usr/local/apr-httpd/lib/libapr- 1.la-lrt
> > > -lcrypt  -lpthread -ldl"
> > > ./configure: line 4280: APR_INCLUDES: command not found
> > > ./configure: line 4281: APR_LIBS: command not found
> > > ./configure: line 4282: APR_LIB_TARGET: command not found
> > > ./configure: line 4283: APR_SO_EXT: command not found
> > > ./configure: line 4284: BASH: command not found
> > > ./configure: line 4285: BASH_ARGC: command not found
> > > ./configure: line 4286: BASH_ARGV: command not found
> > > ./configure: line 4287: BASH_LINENO: command not found
> > > ./configure: line 4288: BASH_SOURCE: command not found
> > > ./configure: line 4289: BASH_VERSINFO: command not found
> > > ./configure: line 4290: BASH_VERSION: command not found
> > > ./configure: line 4291: CC: command not found
> > > ./configure: line 4292: CFLAGS: command not found
> > > ./configure: line 4293: CPP: command not found
> > >
> > >
> > >
> > >
> > >
> > > Line 4288
> > >
> > > _ACEOF
> > >
> > >
> > > # The following way of writing the cache mishandles newlines in
> > values,
> > > # but we know of no workaround that is simple, portable, and
> > efficient.
> > > # So, we kill variables containing newlines.
> > > # Ultrix sh set writes to stderr and can't be redirected directly,
> > > # and sets the high bit in the cache file unless we assign to the
> > vars.
> > > (
> > >   for ac_var in `(set) 2>&1 | sed -n
> > > 's/^\([a-zA-Z_][a-zA-Z0-9_]*\)=.*/\1/p'`; do
> > >     eval ac_val=\$$ac_var
> > >     case $ac_val in #(
> > >     *${as_nl}*)
> > >       case $ac_var in #(
> > >       *_cv_*) { echo "$as_me:$LINENO: WARNING: Cache variable $ac_var
> > > contains a newline." >&5
> > > echo "$as_me: WARNING: Cache variable $ac_var contains a newline."
> > >&2;}
> > > ;;
> > >       esac
> > >       case $ac_var in #(
> > >       _ | IFS | as_nl) ;; #(
> > >       *) $as_unset $ac_var ;;    #line 4288
> > >       esac ;;
> > >     esac
> > >   done
> > >
> > >
> > > Any ideas?
> > >
> > > Orlando
> > >
> > > ---------------------------------------------------------------------
> > > To start a new topic, e-mail: users@tomcat.apache.org
> > > To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
> > > For additional commands, e-mail: users-help@tomcat.apache.org
> > >
> > >
> >
> > ---------------------------------------------------------------------
> > To start a new topic, e-mail: users@tomcat.apache.org
> > To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
> > For additional commands, e-mail: users-help@tomcat.apache.org
> >
> >
>

---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message