tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Per Johnsson" <Per.Johns...@omxgroup.com>
Subject RE: Unable to run Tomcat 5.5.20 as a Windows service under jdk 1.6
Date Tue, 06 Feb 2007 07:31:22 GMT
Hi!

I digged in the source of the service and posted some days ago, but I
have also problems. I think there is some underneeth problem with either
windows 2003 or some settup (user rights/permissions?)

The strange thing in all this is that I managed to run 1.6 with the
service on one machine of 4, so there is probobly some strange
configuration which makes it mess up.

This was my latest conclusion and if someone could dig more into this
and come up with some ide I'm more than happy!

----8<---

I tried to look at the sources:
http://svn.apache.org/viewvc/jakarta/commons/proper/daemon/trunk/src/nat
ive/nt/procrun/src/

I'm not a really into C but someone here could maybe see whats wrong, I
have come to the conclusion that the method: serviceStart()

Is failing on row (~946):
----8<---
/* Set the environment using putenv, so JVM can use it */
setInprocEnvironment();
/* Create the JVM glbal worker */
gWorker = apxCreateJava(gPool, _jni_jvmpath); if
(IS_INVALID_HANDLE(gWorker)) {  apxLogWrite(APXLOG_MARK_ERROR "Failed
creating java %S", _jni_jvmpath);  return 1; }
----8<---

I have tried reinstall both tomcat5.5.20, reinstall jre1.6.0 and
jdk1.6.0 tried all the different options in the java virtual machine
setting in service, from default to jre/client/jvm.dll, jdk/client and
server jvm.dll...

I have run out of options, and I haven't got the knowledge to debug this
furhter, so...

Does anyone know what the IS_INVALID_HANDLE(gWorker) is checking? 
Or why the apxCreateJava(..) is failing why?

/Per Jonsson
 

-----Original Message-----
From: Ken Menzel [mailto:kentomcat@icarz.com] 
Sent: den 5 februari 2007 21:10
To: Tomcat Users List
Subject: Re: Unable to run Tomcat 5.5.20 as a Windows service under jdk
1.6

----- Original Message -----
From: "Grassi Fabio" <Fabio.Grassi@generalisi.it>
To: <users@tomcat.apache.org>
Sent: Monday, February 05, 2007 6:15 AM
Subject: Unable to run Tomcat 5.5.20 as a Windows service under jdk
1.6


On some machines only and only under jdk 1.6 I'm not able to run Tomcat
as a Windows service. Installation of the service goes all right, but
when I try to start the service I get the following error in
jakarta_service.log:

[2007-02-05 12:04:27] [info] Debugging Service...
[2007-02-05 12:04:27] [info] Starting service...
[2007-02-05 12:04:27] [173  javajni.c] [error] Impossibile trovare il
modulo specificato.
[2007-02-05 12:04:27] [924  prunsrv.c] [error] Failed creating java
C:\IRIS_PROGRAMMI\jdk1.6.0\jre\bin\server\jvm.dll
[2007-02-05 12:04:27] [1179 prunsrv.c] [error] ServiceStart returned 1
[2007-02-05 12:04:27] [info] Debug service finished.
[2007-02-05 12:04:27] [info] Procrun finished.

I'm out of options, any idea?

---------------------------------------------------------------------
I was hoping someone would answer you as I am having a similar problem
with JDK 1.6.  I uninstalled 1.6 and installed 1.5 everything seems
fine.  You can find the 1.5 download on the previous release page. 
Tomcat 5.5.20, on Windows 2003 brand new servers from Dell.

[ some cut ]
[2007-02-05 13:17:26] [info] Starting service...
[2007-02-05 13:17:26] [173  javajni.c] [error] The specified module
could not be found.
[2007-02-05 13:17:26] [924  prunsrv.c] [error] Failed creating java
C:\Program Files\Java\jre1.6.0\bin\client\jvm.dll
[2007-02-05 13:17:26] [1179 prunsrv.c] [error] ServiceStart returned 1
[2007-02-05 13:17:26] [info] Run service finished.
[2007-02-05 13:17:26] [info] Procrun finished.

And here after downgrading to 1.5.
[2007-02-05 15:02:51] [info] Service Tomcat5 name Apache Tomcat
[2007-02-05 15:02:51] [info] Service Tomcat5 installed
[2007-02-05 15:02:51] [info] Procrun finished.
[2007-02-05 15:02:52] [info] Updating service...
[2007-02-05 15:02:52] [info] Service Tomcat5 updated
[2007-02-05 15:02:52] [info] Update service finished.
[2007-02-05 15:02:52] [info] Procrun finished.
[2007-02-05 15:02:53] [info] Updating service...
[2007-02-05 15:02:53] [info] Service Tomcat5 updated
[2007-02-05 15:02:53] [info] Update service finished.
[2007-02-05 15:02:53] [info] Procrun finished.
[2007-02-05 15:02:55] [info] Running Service...
[2007-02-05 15:02:55] [info] Starting service...
[2007-02-05 15:02:56] [info] Service started in 1109 ms.

Sorry I can't say any more than that.  Hope it helps.

Ken



---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org To unsubscribe,
e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


********************************************************************************
This e-mail and the information it contains may be privileged and/or
confidential.  It is for the intended addressee(s) only.
The unauthorised use, disclosure or copying of this e-mail, or any information it contains,
is prohibited. 
If you are not an intended recipient, please contact the sender and delete the material from
your computer.
********************************************************************************



---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message