tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Baron, Bob \(LNG-OAK\)" <Bob.Ba...@lexisnexis.com>
Subject isapi_redirect problem when servlet mapping is the same as the host
Date Thu, 22 Feb 2007 17:18:31 GMT
I'm wondering if there is some kind of easy solution to this problem
that won't require a customization to work around it.
 
The problem occurs when the machine name matches the servlet name (e.g.
http://foo/foo). The problem is that the isapi_redirect is processing
all traffic going to the site and not allowing other filters to handle
them.
 
I have a servlet mapped using the name of our product:
 
    <servlet-mapping>
      <servlet-name>myservlet</servlet-name> 
      <url-pattern>/myproductname/*</url-pattern> 
    </servlet-mapping>
 
If the name of the machine is also myproductname, things are fine for
request that are intended for our servlet (e.g.
http://myproductname/myproductname/whatever)
 
If there is something else that should be served up by IIS (e.g.
http://myproductname/images/image.gif), the request is passed off to our
servlet instead of dropping through to let IIS serve it up from a
Virtual Directory. Same hold for .Net applications and anything else on
the box - major problem!
 
Has anyone had this problem before? Why is the name of the server used
in the filtering and is there a way to ignore it?
 
If not, I already have a version that suppresses using the host name in
the filtering and it clears up my problem - should this be considered
for an enhancement?
 
Bob Baron
Bob.Baron@LexisNexis.com <mailto:Bob.Baron@LexisNexis.com> 



 

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message