tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Anthony Liu <antonyliu2...@yahoo.com>
Subject Problem seting up Tomcat SSL
Date Tue, 20 Feb 2007 01:01:26 GMT
Hi, people,

It's been 3 years since I used Tomcat the last time.  When I return to it these days, I am
having a hard time getting the SSL to work.

I've created a keystore using keytool and put the .keystore file under C:\Tomcat_6\conf\

I am using JRE 6.

After I read the on-line doc, I put this in the server.xml:


<-- Define a non-blocking Java SSL Coyote HTTP/1.1 Connector on port 8443 -->

<Connector protocol="org.apache.coyote.http11.Http11NioProtocol"
           port="8443" minSpareThreads="5" maxSpareThreads="75"
           enableLookups="true" disableUploadTimeout="true" 
           acceptCount="100"  maxThreads="200"
           scheme="https" secure="true" SSLEnabled="true"
           keystoreFile="C:/Tomcat_6/conf/.keystore" keystorePass="changeit"
           clientAuth="false" sslProtocol="TLS"/>

Turning the SSLEngine on or off makes no difference.

  <!--APR library loader. Documentation at /docs/apr.html -->
  <Listener className="org.apache.catalina.core.AprLifecycleListener" SSLEngine="on" />

So, what's going on?  What I am missing?

By the way, I am not sure what is APR, and I did not install native libraries at Tomcat Installation.

Thanks.

 
---------------------------------
TV dinner still cooling?
Check out "Tonight's Picks" on Yahoo! TV.
Mime
  • Unnamed multipart/alternative (inline, 8-Bit, 0 bytes)
View raw message