tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kirk <synchroph...@gmail.com>
Subject Compiling mod-jk plugin for SunOne on Solaris
Date Wed, 21 Feb 2007 20:25:00 GMT
There was a thread from February 1st on this same issue.  I am having the
same problem that person did, but I tried everything in the thread and still
no luck.

After I get mod_jk compiled I get this on server startup:

failure: CORE3170: Configuration initialization failed: Error running
init function load-modules:
dlopen of /wamu/hr/sunone/plugins/mod_jk/nsapi_redirector.so failed
(ld.so.1: webservd: fatal:
relocation error: file
/wamu/hr/sunone/plugins/mod_jk/nsapi_redirector.so: symbol __lshrdi3:
referenced symbol not found)


The one thing that I think is making a difference as compared to the person
in the earlier thread is that gcc is not installed on the server I am trying
to deploy on and I am not allowed to have it on there.  it is not an option,
don't ask.  I tried static linking, but I have a feeling I am doing it
wrong.

So, my question is, what exactly do I need to do to compile the mod_jk
plugin for SunOne on Solaris where it is to be deployed on a server that
does not have gcc installed at all?

Thanks,
Kirk

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message