tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jim Jagielski <...@jaguNET.com>
Subject Re: Compiling mod-jk plugin for SunOne on Solaris
Date Fri, 23 Feb 2007 14:41:40 GMT

On Feb 21, 2007, at 3:25 PM, Kirk wrote:

> There was a thread from February 1st on this same issue.  I am  
> having the
> same problem that person did, but I tried everything in the thread  
> and still
> no luck.
>
> After I get mod_jk compiled I get this on server startup:
>
> failure: CORE3170: Configuration initialization failed: Error running
> init function load-modules:
> dlopen of /wamu/hr/sunone/plugins/mod_jk/nsapi_redirector.so failed
> (ld.so.1: webservd: fatal:
> relocation error: file
> /wamu/hr/sunone/plugins/mod_jk/nsapi_redirector.so: symbol __lshrdi3:
> referenced symbol not found)
>
>
> The one thing that I think is making a difference as compared to  
> the person
> in the earlier thread is that gcc is not installed on the server I  
> am trying
> to deploy on and I am not allowed to have it on there.  it is not  
> an option,
> don't ask.  I tried static linking, but I have a feeling I am doing it
> wrong.
>

I would download and use SunStudio. With Sun's own 'cc' you
don't get these errors with gcc assuming that glib/gld will be
pulling in these gcc/glib artifacts.

The Makefile.solaris is updated in trunk (and thus in 1.2.21)
with the cc params


---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message