tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Propes, Barry L [GCG-NAOT]" <barry.l.pro...@citigroup.com>
Subject startup error
Date Thu, 15 Feb 2007 19:01:44 GMT
Hi folks, I was trying to get DBCP working and tried adding the Resource param info per the
TC 4.1 documentation:
 
<Context path="/DBTest" docBase="DBTest"
debug="5" reloadable="true" crossContext="true">
<Logger className="org.apache.catalina.logger.FileLogger"
prefix="localhost_DBTest_log." suffix=".txt"
timestamp="true"/>

<Resource name="jdbc/myoracle" auth="Container"
type="javax.sql.DataSource"/> 

<ResourceParams name="jdbc/myoracle">
<parameter>
<name>factory</name>
<value>org.apache.commons.dbcp.BasicDataSourceFactory</value>
</parameter>
<parameter>
<name>driverClassName</name>
<value>oracle.jdbc.OracleDriver</value>
</parameter>
<parameter>
<name>url</name>
<value>jdbc:oracle:thin:@169.xxx.xx.xxx:1521:SID</value>
</parameter>
<parameter>
<name>username</name>
<value>usernameval</value>
</parameter>
<parameter>
<name>password</name>
<value>passwordval</value>
</parameter>
<parameter>
<name>maxActive</name>
<value>20</value>
</parameter>
<parameter>
<name>maxIdle</name>
<value>10</value>
</parameter>
<parameter>
<name>maxWait</name>
<value>-1</value>
</parameter>
</ResourceParams>
</Context>

---------------------------------

and I get the following message on my console, followed by an abrupt shutdown immediately.

C:\jakarta-tomcat-4.1.31\bin>rem @echo off

C:\jakarta-tomcat-4.1.31\bin>if "Windows_NT" == "Windows_NT" setlocal

C:\jakarta-tomcat-4.1.31\bin>rem -----------------------------------------------
----------------------------

C:\jakarta-tomcat-4.1.31\bin>rem Start script for the CATALINA Server

C:\jakarta-tomcat-4.1.31\bin>rem

C:\jakarta-tomcat-4.1.31\bin>rem $Id: startup.bat,v 1.4 2002/01/15 02:55:38 patr
ickl Exp $

C:\jakarta-tomcat-4.1.31\bin>rem -----------------------------------------------
----------------------------

C:\jakarta-tomcat-4.1.31\bin>rem Guess CATALINA_HOME if not defined

C:\jakarta-tomcat-4.1.31\bin>if not "" == "" goto gotHome

C:\jakarta-tomcat-4.1.31\bin>set CATALINA_HOME=.

C:\jakarta-tomcat-4.1.31\bin>if exist ".\bin\catalina.bat" goto okHome

C:\jakarta-tomcat-4.1.31\bin>set CATALINA_HOME=..

C:\jakarta-tomcat-4.1.31\bin>if exist "..\bin\catalina.bat" goto okHome

C:\jakarta-tomcat-4.1.31\bin>set EXECUTABLE=..\bin\catalina.bat

C:\jakarta-tomcat-4.1.31\bin>rem Check that target executable exists

C:\jakarta-tomcat-4.1.31\bin>if exist "..\bin\catalina.bat" goto okExec

C:\jakarta-tomcat-4.1.31\bin>rem Get remaining unshifted command line arguments
and save them in the

C:\jakarta-tomcat-4.1.31\bin>set CMD_LINE_ARGS=

C:\jakarta-tomcat-4.1.31\bin>if """" == """" goto doneSetArgs

C:\jakarta-tomcat-4.1.31\bin>call "..\bin\catalina.bat" start
Using CATALINA_BASE:   ..
Using CATALINA_HOME:   ..
Using CATALINA_TMPDIR: ..\temp
Using JAVA_HOME:       C:\j2sdk1.4.0
C:\jakarta-tomcat-4.1.31\bin>

 

Any idea what could be out of place here? If I remove the above attributes for the resource
params, the error doesn't occur.

Any feedback would be appreciated -- thanks.

 


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message