tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rahul Choubey <c_rahul...@yahoo.com>
Subject Problem running servlets on tomcat
Date Tue, 13 Feb 2007 05:17:43 GMT
Dear Friends,
   
  I am having a problem running servlets on the browser using Tomcat.I am using Apache Tomcat
4.1.34 and am saving the .class file at the following location in my system:-
   
  E:\Program Files\apache-tomcat-4.1.34\webapps\rahul\Web-Inf\classes
   
  rahul\Web-Inf\classes being the folders created by me.
   
  I have also copied the web.xml to:
  E:\Program Files\apache-tomcat-4.1.34\webapps\rahul
   
  and altered the file(web.xml at above secified location) is:-
   
  <web-app>
<display-name>rahul</display-name>
<description>Rahul Test Servlet</description>
<servlet>
        <servlet-name>HelloWorld</servlet-name>
        <servlet-class>HelloServlet</servlet-class>
</servlet>
    <servlet-mapping>
        <servlet-name>HelloWorld</servlet-name>
        <url-pattern>/chk/res</url-pattern>
    </servlet-mapping>
</web-app>

  HelloServlet being the class name of the servlet program.
   
   
  http://localhost:8080/rahul/chk/res on putting this in the address bar of my browser I get
the following error:
   
  Apache Tomcat/4.1.34- HTTP Status 404 - /rahul/chk/res

  type Status report
  message /rahul/chk/res
  description The requested resource (/rahul/chk/res) is not available.
   
   
  Please Help me.
   
  Regards,
  Rahul
  





 
---------------------------------
Don't be flakey. Get Yahoo! Mail for Mobile and 
always stay connected to friends.
Mime
  • Unnamed multipart/alternative (inline, 8-Bit, 0 bytes)
View raw message