tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From wille <wilh...@ling.su.se>
Subject URL-pointing problem
Date Tue, 27 Feb 2007 15:15:10 GMT
Hello,

having a bit of a problem here.


We have deployed a web application on our server by putting it in the
webapps directory, this makes it appear at a URL like
http://mjau.com/pub_db. Now we want to change the URL for this webapp to
something else, (in this case http://mjau.com/publications). 

Currently we've tried messing around with URL-mapping
in /tomcat5/conf/web.xml and /tomcat5/webapps/WEB-INF/web.xml.


We've tried to use the servlet-mapping directive in our web data
xml-files, but it seems that the servlet is implicitly defined when
putting the webapp in the webapps directory, because we have no servlet
section in our web data xml-files. But things work anyway.

But when we try to define our own servlet section, it won't work.

We are running Tomcat 5.0.30, Java 5.0, on a Debian Etch server.




This is what we've tried to do in the /tomcat5/conf/web.xml:

	<servlet>
            <servlet-name>pubdb</servlet-name>
                    <servlet-class>
                        pubdb
                      </servlet-class>
              </servlet>-->

  <!--<servlet-mapping>
  <servlet-name>invoker</servlet-name>
  <url-pattern>/publications/*</url-pattern>
</servlet-mapping>-->

</web-app>





Anyone have a clue what we're doing wrong?


---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message