tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ken Menzel" <kentom...@icarz.com>
Subject Re: Unable to run Tomcat 5.5.20 as a Windows service under jdk 1.6
Date Mon, 05 Feb 2007 20:09:38 GMT
----- Original Message ----- 
From: "Grassi Fabio" <Fabio.Grassi@generalisi.it>
To: <users@tomcat.apache.org>
Sent: Monday, February 05, 2007 6:15 AM
Subject: Unable to run Tomcat 5.5.20 as a Windows service under jdk 
1.6


On some machines only and only under jdk 1.6 I'm not able to run 
Tomcat
as a Windows service. Installation of the service goes all right, but
when I try to start the service I get the following error in
jakarta_service.log:

[2007-02-05 12:04:27] [info] Debugging Service...
[2007-02-05 12:04:27] [info] Starting service...
[2007-02-05 12:04:27] [173  javajni.c] [error] Impossibile trovare il
modulo specificato.
[2007-02-05 12:04:27] [924  prunsrv.c] [error] Failed creating java
C:\IRIS_PROGRAMMI\jdk1.6.0\jre\bin\server\jvm.dll
[2007-02-05 12:04:27] [1179 prunsrv.c] [error] ServiceStart returned 1
[2007-02-05 12:04:27] [info] Debug service finished.
[2007-02-05 12:04:27] [info] Procrun finished.

I'm out of options, any idea?

---------------------------------------------------------------------
I was hoping someone would answer you as I am having a similar problem 
with JDK 1.6.  I uninstalled 1.6 and installed 1.5 everything seems 
fine.  You can find the 1.5 download on the previous release page. 
Tomcat 5.5.20, on Windows 2003 brand new servers from Dell.

[ some cut ]
[2007-02-05 13:17:26] [info] Starting service...
[2007-02-05 13:17:26] [173  javajni.c] [error] The specified module 
could not be found.
[2007-02-05 13:17:26] [924  prunsrv.c] [error] Failed creating java 
C:\Program Files\Java\jre1.6.0\bin\client\jvm.dll
[2007-02-05 13:17:26] [1179 prunsrv.c] [error] ServiceStart returned 1
[2007-02-05 13:17:26] [info] Run service finished.
[2007-02-05 13:17:26] [info] Procrun finished.

And here after downgrading to 1.5.
[2007-02-05 15:02:51] [info] Service Tomcat5 name Apache Tomcat
[2007-02-05 15:02:51] [info] Service Tomcat5 installed
[2007-02-05 15:02:51] [info] Procrun finished.
[2007-02-05 15:02:52] [info] Updating service...
[2007-02-05 15:02:52] [info] Service Tomcat5 updated
[2007-02-05 15:02:52] [info] Update service finished.
[2007-02-05 15:02:52] [info] Procrun finished.
[2007-02-05 15:02:53] [info] Updating service...
[2007-02-05 15:02:53] [info] Service Tomcat5 updated
[2007-02-05 15:02:53] [info] Update service finished.
[2007-02-05 15:02:53] [info] Procrun finished.
[2007-02-05 15:02:55] [info] Running Service...
[2007-02-05 15:02:55] [info] Starting service...
[2007-02-05 15:02:56] [info] Service started in 1109 ms.

Sorry I can't say any more than that.  Hope it helps.

Ken



---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message