tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Martin Gainty" <mgai...@hotmail.com>
Subject Re: XML Parse problem in a webapp context.xml
Date Sun, 28 Jan 2007 13:49:18 GMT
Pete--

I would run your xml thru a DOM Validator to test for malformed elements or attributes
http://www.w3schools.com/dom/dom_validate.asp

HTH
Martin --
--------------------------------------------------------------------------- 
This e-mail message (including attachments, if any) is intended for the use of the individual
or entity to which it is addressed and may contain information that is privileged, proprietary
, confidential and exempt from disclosure. If you are not the intended recipient, you are
notified that any dissemination, distribution or copying of this communication is strictly
prohibited.
--------------------------------------------------------------------------- 
Le présent message électronique (y compris les pièces qui y sont annexées, le cas échéant)
s'adresse au destinataire indiqué et peut contenir des renseignements de caractère privé
ou confidentiel. Si vous n'êtes pas le destinataire de ce document, nous vous signalons qu'il
est strictement interdit de le diffuser, de le distribuer ou de le reproduire.
----- Original Message ----- 
From: "Pete" <pwkpete@yahoo.com>
To: "Tomcat Users List" <users@tomcat.apache.org>
Sent: Sunday, January 28, 2007 12:25 AM
Subject: Re: XML Parse problem in a webapp context.xml


No problem Mark.

I suspected the error was just some message inconsistency. It was a bit confusing at first,
but determined it wasn't that file via trial and error. (And a little snooping in the code.)

There is a partial stack trace in the original message ( cut the middle out), but I can get
the complete one for you on Monday.

-P

----- Original Message ----
From: Mark Thomas <markt@apache.org>
To: Tomcat Users List <users@tomcat.apache.org>
Sent: Saturday, January 27, 2007 2:16:25 PM
Subject: Re: XML Parse problem in a webapp context.xml

Pete wrote:
> Mark,
> 
> I stated in the original message that the conf/web.xml is unmodified and the problem
only happens with certain contents in the META-INF/context.xml after it gets moved from the
app into conf/Catalina/localhost directory.
> 
> -P

Sorry - my bad. I should have read your post more carefully.

I have had a look at the source and the reference to conf/web.xml is
caused by a bug. It is the context.xml that is having the problem.
I'll get this fixed.

Is the stack trace you posted with your original message all you have?
It looks like you might have left some bits out. A more complete stack
trace, if available, might help track this down.

Mark


---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org






 
____________________________________________________________________________________
Food fight? Enjoy some healthy debate 
in the Yahoo! Answers Food & Drink Q&A.
http://answers.yahoo.com/dir/?link=list&sid=396545367

---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org

Mime
View raw message