tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Caldarale, Charles R" <Chuck.Caldar...@unisys.com>
Subject RE: tomcat 5.5, java 6 and jconsole not working as service
Date Tue, 09 Jan 2007 17:08:33 GMT
> From: news [mailto:news@sea.gmane.org] On Behalf Of teknokrat
> Subject: tomcat 5.5, java 6 and jconsole not working as service
> 
> I am running Tomcat 5.5 as a service using Java 6. I try to connect 
> jconsole locally but it can't seem to find tomcat.

By default, JConsole only connects to local JVMs running under the same
userid.  Unless you've modified the Log On settings for the Tomcat
service, it's running under Local System Account, not your normal
userid.  Also, you have to add -Dcom.sun.management.jmxremote to the
Java Options for the service, using the tomcat5w.exe utility.  Once
those were done, I was able to connect to the Tomcat service using
JConsole running with JDK 6.

However, I am now noticing something very strange: most of the apps did
not deploy when running as a service.  Only ROOT, host-manager, manager,
and tomcat-docs show up in the application list.  When running with
startup.bat, everything's there.  More investigation needed.

 - Chuck


THIS COMMUNICATION MAY CONTAIN CONFIDENTIAL AND/OR OTHERWISE PROPRIETARY
MATERIAL and is thus for use only by the intended recipient. If you
received this in error, please contact the sender and delete the e-mail
and its attachments from all computers.

---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message