tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Zaphod <Ralf.Stoff...@BVG.DE>
Subject Tomcat 6.0.8 & JSF 1.2 RI
Date Mon, 22 Jan 2007 17:24:40 GMT

I try to use the JSF 1.2_03 RI with Tomcat 6.0.8.

I get a NullPointerException:
Servlet.service() for servlet jsp threw exception
java.lang.NullPointerException
	at org.apache.jsp.VDVRequest_jsp._jspInit(VDVRequest_jsp.java:25)
	at org.apache.jasper.runtime.HttpJspBase.init(HttpJspBase.java:80)
	at
org.apache.jasper.servlet.JspServletWrapper.getServlet(JspServletWrapper.java:157)
	at
org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:320)
	at org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:320)
	at org.apache.jasper.servlet.JspServlet.service(JspServlet.java:266)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:803)
	at
org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290)
	at
org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
	at
org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:228)
	at
org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:175)
	at
org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:128)
	at
org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:105)
	at
org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
	at
org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:212)
	at
org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:844)
	at
org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:634)
	at org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:445)
	at java.lang.Thread.run(Unknown Source)


in VDVRequest_jsp.java:
  public void _jspInit() {
    _005fjspx_005ftagPool_005ff_005fview =
org.apache.jasper.runtime.TagHandlerPool.getTagHandlerPool(getServletConfig());
    _005fjspx_005ftagPool_005fh_005foutputText_005fvalue_005fnobody =
org.apache.jasper.runtime.TagHandlerPool.getTagHandlerPool(getServletConfig());
[here is line no. 25:]
    _el_expressionfactory =
JspFactory.getDefaultFactory().getJspApplicationContext(getServletConfig().getServletContext()).getExpressionFactory();
    _jsp_annotationprocessor = (org.apache.AnnotationProcessor)
getServletConfig().getServletContext().getAttribute(org.apache.AnnotationProcessor.class.getName());
  }

I suppose JspFactory.getDefaultFactory() is null.
But why?
I suppose it is a configuration problem or a tomcat bug.

I have the jsf-api, jsf-impl and jstl JARs in my lib folder and I switched
verfication off.

Is there any workaround to initialize the JspFactory?


-- 
View this message in context: http://www.nabble.com/Tomcat-6.0.8---JSF-1.2-RI-tf3059080.html#a8505670
Sent from the Tomcat - User mailing list archive at Nabble.com.


---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message