tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alessandro Ilardo <alessandro.ila...@my-sandro.net>
Subject REALM and JNDI configuration
Date Tue, 30 Jan 2007 11:33:58 GMT
I'm having some trouble when I attempt to authenticate myself into my 
web application using the REALM.
I always get the error login page. Would you have a look on my 
configuration reported belowe as for the first time I'm trying to 
connect it to the database via JNDI.
Thanks in advance for you support.

<?xml version="1.0" encoding="UTF-8"?>
<Context path="/allysia" reloadable="true">
    <Resource name="jdbc/allysiaDB" auth="Container" 
type="javax.sql.DataSource"
    username="allysia" password="xxxxxxxxxxx"
    driverClassName="org.gjt.mm.mysql.Driver"
    url="jdbc:mysql://127.0.0.2:3306/test?autoReconnect=true" 
maxActive="100" maxIdle="30"
    maxWait="10000"/>
    <Realm className="org.apache.catalina.realm.DataSourceRealm"
    name="jdbc/allysiaDB" digest="MD5" localDataSource="true"
    debug="99" roleNameCol="role" userCredCol="password" 
userNameCol="username"
    userRoleTable="role" userTable="user"/>
    <Valve className="org.apache.catalina.valves.AccessLogValve"
    directory="logs"  prefix="allysia_access_log." suffix=".txt"
    pattern="common" resolveHosts="false"/>
</Context>


---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message