tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jose Rafael Romero Miret <jrom...@dunasoft.es>
Subject SSL Configuration works but half the way + logs
Date Fri, 26 Jan 2007 12:15:42 GMT
I configured tomcat as standalone server and now i want to configure 
ssl. I did that as the book I have said and also like the documentation 
in the website tells me.

after the configuration i get this:
 http://localhost:443/ gives me tomcat website.
 https://localhost:443/ gives me connected status in the browser with no 
result... it waits until some timeout gets up.

My configuration:

i'm using java sdk 1.6.0, Apache Tomcat/5.5.20 for windows and no, as 
far as I know I never installed Apache Portable Runtime Project just the 
tomcat  service installer.

keytool.exe -genkey -alias tomcat -keyalg RSA -keystore c:/keystore.key 
-keypass 123456 -storepass 123456 -keysize 2048

<Connector
        port="443" minProcessors="5" maxProcessors="75" algorithm="RSA"
        enableLookups="true" disableUploadTimeout="true"
        acceptCount="100" debug="4" scheme="https" secure="true"
        clientAuth="want" sslProtocol="TLS" 
keystoreFile="c:/keystore.key" keystorePass="123456"/>

I know i added a lot of small options that perhaps are not needed, but 
in the simpler way is not working anyway.

Hope someone can help me on this, so far i've been trying to get it work 
for the past 2 days and it's fustrating.

[catalina.2007-01-26]

26-ene-2007 11:33:27 org.apache.coyote.http11.Http11AprProtocol init
INFO: Inicializando Coyote HTTP/1.1 en puerto http-80
26-ene-2007 11:33:27 org.apache.coyote.ajp.AjpAprProtocol init
INFO: Initializing Coyote AJP/1.3 on ajp-8009
26-ene-2007 11:33:27 org.apache.coyote.http11.Http11AprProtocol init
INFO: Inicializando Coyote HTTP/1.1 en puerto http-443
26-ene-2007 11:33:27 org.apache.catalina.startup.Catalina load
INFO: Initialization processed in 953 ms
26-ene-2007 11:33:27 org.apache.catalina.core.StandardService start
INFO: Arrancando servicio Catalina
26-ene-2007 11:33:27 org.apache.catalina.core.StandardEngine start
INFO: Starting Servlet Engine: Apache Tomcat/5.5.20
26-ene-2007 11:33:27 org.apache.catalina.core.StandardHost start
INFO: Desactivada la validaciĆ³n XML
26-ene-2007 11:33:28 org.apache.coyote.http11.Http11AprProtocol start
INFO: Arrancando Coyote HTTP/1.1 en puerto http-80
26-ene-2007 11:33:29 org.apache.coyote.ajp.AjpAprProtocol start
INFO: Starting Coyote AJP/1.3 on ajp-8009
26-ene-2007 11:33:29 org.apache.coyote.http11.Http11AprProtocol start
INFO: Arrancando Coyote HTTP/1.1 en puerto http-443
26-ene-2007 11:33:29 org.apache.catalina.storeconfig.StoreLoader load
INFO: Find registry server-registry.xml at classpath resource
26-ene-2007 11:33:29 org.apache.catalina.startup.Catalina start
INFO: Server startup in 2063 ms


[localhost.2007-01-26]

26-ene-2007 11:33:28 org.apache.catalina.core.ApplicationContext log
INFO: org.apache.webapp.balancer.BalancerFilter: init(): ruleChain: 
[org.apache.webapp.balancer.RuleChain: 
[org.apache.webapp.balancer.rules.URLStringMatchRule: Target string: 
News / Redirect URL: http://www.cnn.com], 
[org.apache.webapp.balancer.rules.RequestParameterRule: Target param 
name: paramName / Target param value: paramValue / Redirect URL: 
http://www.yahoo.com], 
[org.apache.webapp.balancer.rules.AcceptEverythingRule: Redirect URL: 
http://jakarta.apache.org]]
26-ene-2007 11:33:28 org.apache.catalina.core.ApplicationContext log
INFO: ContextListener: contextInitialized()
26-ene-2007 11:33:28 org.apache.catalina.core.ApplicationContext log
INFO: SessionListener: contextInitialized()
26-ene-2007 11:33:28 org.apache.catalina.core.ApplicationContext log
INFO: ContextListener: contextInitialized()
26-ene-2007 11:33:28 org.apache.catalina.core.ApplicationContext log
INFO: SessionListener: contextInitialized()

Rest of the logs are empty.

26-ene-2007 11:33:29 org.apache.coyote.http11.Http11AprProtocol start
INFO: Arrancando Coyote HTTP/1.1 en puerto http-443

If you see here the protocol is coyote http/1.1 and the ssl conector is 
defined scheme="https" so i donno what is happening.



Mime
View raw message