tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tim Funk <funk...@joedog.org>
Subject Re: authentication using active directory
Date Fri, 26 Jan 2007 11:58:28 GMT
Most likely - you need to remove /gridsphere from your login config

-Tim

Deepan wrote:
> Hi,
>  I am trying to authenticate using Active directory for one my
> application in tomcat. ( I have only one application deployed in
> tomcat). 
> 
> I had configured server.xml and web.xml to use /gridsphere/login.html to
> get details from user and authenticate using AD. When i hit the url
> "localhost:8080", i get 404 error, saying "The requested resource
> (/gridsphere/login.html) is not available. " 
> 
> 
> 
> 
> -----------------------------------------------------------
> server.xml 
> 
> <Realm className="org.apache.catalina.realm.JNDIRealm" debug="99"
> 
> connectionURL="ldap://172.168.1.1:389"
> connectionName="tomcatuser@gs.novaglobal.com.sg"
> connectionPassword="xxxxxxxx"
> referrals="follow"
> userRoleName="member"
> roleSearch="(member={0})"
> roleSubtree="false"
> userSubtree="true"
> />
> 
> --------------------------------------------------------------
> 
> web.xml

<SNIP>
> 
> <form-login-page>/gridsphere/index.html</form-login-page>
> 
> <form-error-page>/gridsphere/autherr.html</form-error-page>
>         </form-login-config>
> </login-config>


---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message