tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Arnaud MERGEY <amer...@sunopsis.com>
Subject Re: something wrong creating datasource after war deployement
Date Mon, 08 Jan 2007 15:35:06 GMT
thanks,

I updated the META-INF/context.xml in the unpacked directory,
this is strange because when I update the META-INF/context.xml, I can 
see newly  datasources in the tomcat admin webapps (but with blank 
driver class and url info).
If I update META-INF/context.xml in application without war file in 
webapps, everything works and I can see newly  datasources in the tomcat 
admin webapps with driver class and url.

Arnaud

Caldarale, Charles R a écrit :
>> From: Arnaud MERGEY [mailto:amergey@sunopsis.com] 
>> Subject: Re: something wrong creating datasource after war deployement
>>
>> Like you, I think there is a conflict between context.xml in 
>> war and in unpacked directory (because wtihout war all works
>> as expected)
>>     
>
> As David mentioned earlier, when a .war is unpacked, its
> META-INF/context.xml file is copied to
> conf/Catalina/[host]/[appname].xml, and that becomes the active copy.
> Changing the one in the unpacked directory will have no effect, since
> the one in the conf/Catalina/[host] directory is defined to override the
> one in the app.
>
> Which one are you updating?
>
>  - Chuck
>
>
> THIS COMMUNICATION MAY CONTAIN CONFIDENTIAL AND/OR OTHERWISE PROPRIETARY
> MATERIAL and is thus for use only by the intended recipient. If you
> received this in error, please contact the sender and delete the e-mail
> and its attachments from all computers.
>
> ---------------------------------------------------------------------
> To start a new topic, e-mail: users@tomcat.apache.org
> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
> For additional commands, e-mail: users-help@tomcat.apache.org
>
>
>   


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message