tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "david.delbecq" <david.delb...@oma.be>
Subject Re: Tomcat cache problem?
Date Tue, 02 Jan 2007 23:39:07 GMT
To make it short, tomcat does no caching of servlet / jsp output. Your
webapp is at fault


All tomcat does is handle the 'if-modified-since' header when serving
static data (what is not served by a servlet or a jsp, mainly pictures,
static html, css). The fact it goes back well when you restart tomcat
points out it's a problem with you specific web application. As you have
no knowledge of what is inside this web application, i suggest you check
with the vendor and or developpers of that specific web application.


If you want confirmation, just restart your webapplication without
restarting tomcat (use the manager or lambda probe for that)

reference:

tomcat manager http://tomcat.apache.org/tomcat-5.5-doc/manager-howto.html
lambda probe http://www.lambdaprobe.org

markx3 a écrit :
> Hello, 
>
> I have a server running Windows 2003 server SP1.  8 GB of RAM.  Sun Java
> J2SE 5.0 update 7 and Tomcat 5.5.20. 
>
> Tomcat is used as our web server to review archived email.  The email is
> stored in folders on the server and the archival system uses MS SQL 2000 SP4
> on the backend. 
>
> The problem is when we use Tomcat as our web server to review the email, and
> we click on several emails, after awhile regardless of the different email
> we click on, we get the same data displayed in our web browser.  This really
> appears to be a caching issue with Tomcat, because every time we restart the
> tomcat service, the problem goes away for a few days and then it happens
> again.   
>
> To try to fix the issue we gave Tomcat more memory in the Tomcat Properties
> / Java tab.  We set initial memory pool to 128 MB of RAM and maximum memory
> pool to 512 MB of RAM.  We also tried setting the IE 6.0 and 7.0 browsers to
> check for newer versions of the page every time I visit the webpage.  Both
> of these attempts didn’t resolve the issue. 
>
> Since I’m not a web developer I don’t know what to tell you about the
> website tomcat is hosting.  Except for that it was a .war file that tomcat
> extracts once we place in into the tomcat5.5\webapps directory.  If you need
> specifics on what this website is, please let me know and I can get that
> info for you.  But looking through it there are all the usual files like
> .jsp, .htm, etc. 
>
> Also there isn’t a proxy server on the network.  When users connect to the
> website tomcat is hosting, the browser on the local machine is making a
> direct connection since it’s on the same subnet. 
>
> Please let me know what suggestions we can use to try to resolve this issue. 
>
>   


---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message