tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Propes, Barry L [GCG-NAOT]" <barry.l.pro...@citigroup.com>
Subject RE: downloading JSTL..
Date Tue, 09 Jan 2007 20:48:16 GMT
so would I just dump all of the .tld files in my WEB-INF sub directory titled tlds?

For instance, I've got a directory in my webapps folder, then a WEB-INF directory for it,
then inside it I've got a directory titled tlds.

Just throw them in there?

-----Original Message-----
From: Wendy Smoak [mailto:wsmoak@gmail.com]
Sent: Monday, August 21, 2006 10:34 PM
To: Tomcat Users List
Subject: Re: downloading JSTL..


> Wendy, thank you very much for your help.. I'm using Tomcat 5, so I
> figured had to use JSTL 1.1..

No.  The version of JSTL to use depends on what version of the Servlet
spec your webapp is configured to use, not what version of Tomcat
they're running in.


> my Servlet API is 2.4.. so looking on pg you pointed out, put this on
> top of web.xml:
>
> <web-app xmlns="http://java.sun.com/xml/ns/j2ee"
>            xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
>   xsi:schemaLocation="http://java.sun.com/xml/ns/j2ee
>                       http://java.sun.com/xml/ns/j2ee/web-app_2_4.xsd"
>              version="2.4">
>
> also changed URI for JSTL 1.1 like you said, so now in JSP have:
>
> <%@ taglib uri="http://java.sun.com/jsp/jstl/core" prefix="c" %>
> <c:out value="Congratulations, JSTL is working!"/>
>
> still, get exact same error..  oh brother, I don't get this..

The error you're getting has to do with parsing an XML file, probably
web.xml.  It's complaining that:

> SEVERE: Parse Fatal Error at line 3 column 6: The processing instruction
> target matching "[xX][mM][lL]" is not allowed.

Delete the two lines above, and any spaces before, the <?xml
version="1.0"?> (or similar) which is on line 3.  It has to be the
very first thing in the file.

> (actually the guy says in book he's using Tomcat 5.5 (which I know is
> for java sdk 1.5, I'm using tomcat 5.0.23 or something, and sdk 1.4, but
> since am on Tomcat 5 figured JSTL 1.1 would be ok..)

Yes, it should be fine.

> (this pg refers to Struts, though.. I'm not using Struts, have never
> used Struts..

... which is why I said, "Ignore the Struts-related parts." :)

-- 
Wendy

---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message