tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Irek Matysiewicz <ire...@poczta.fm>
Subject Can't register Tomcat as Windows service on some computers
Date Thu, 04 Jan 2007 11:10:44 GMT

When I use Java 1.6.0:
Tomcat started using startup.bat works fine.
When started using tomcat5.exe does nothing, and exits.
When registered as a Windows service, and started using:

net start tomcat5

There is a meaningless error message on the console, but in
jakarta_service.log I find:

[2006-12-21 16:59:48] [173  javajni.c] [error] Can't create the specified
module.
[2006-12-21 16:59:48] [764  prunsrv.c] [error] Failed creating java
D:\Programs\Java\jdk1.6.0\jre\bin\server\jvm.dll
[2006-12-21 16:59:48] [982  prunsrv.c] [error] ServiceStart returned 1

This problem occurs on Tomcat 5.0.28, and Tomcat 6.

When I use Java 1.5.0 everything works fine. 
What's more strange: This problem occurs on Celeron 3000. On other computers with Intel Core
2 Duo E6300 or Pentium 4 3000 everything works fine. All the computers have the same OS (Windows
XP SP2). Is this a problem with Tomcat or Java?

How to solve this problem?


----------------------------------------------------------------------
Jestes kierowca? To poczytaj! >>> http://link.interia.pl/f199e


---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message