tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Keith Bottner" <ke...@bottner.net>
Subject Manager deployment for ROOT.war not working properly.
Date Wed, 03 Jan 2007 00:21:16 GMT
I am documentation and Googled out. I am attempting to use the Tomcat
Manager so that I can script deployment to a Farm of servers. I soon found
out that deploying a ROOT web application does not work.
 
# curl -u manager:passsword -T /home/manager/ROOT.war
http://10.0.0.2/manager/deploy?path=/
 
It always deploys the application as /ROOT.war
 
Now this works perfectly if I do it from http://10.0.0.2/manager/html and
use the Web interface to upload the ROOT.war. It deploys to / with no
problems. But if I use the non HTML version it will not deploy to /
properly.
 
FYI
- I use this same technique on NON root based web applications with no
problems, works like a charm.
- The context.xml file in the WAR file is correct.
- Yes I tried renaming the file to .war as a hack to get around the problem
and that did not work, it deployed to .war.war
- Yes I tried leaving the path attribute as blank (like part of the
documentation suggests) and it returns an error "FAIL - Invalid context path
was specified" even though the documentation explicitly says to leave it
blank when deploying the root web application.
 
I do believe that this is a legitimate bug but I need some way to workaround
the issue since I can't wait to solve this until the next version of Tomcat
is released.
 
Thanks in advance for your help,
 
Keith

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message