tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tsirkin Evgeny" <tsir...@gmail.com>
Subject Re: strange ssl tomcat response
Date Thu, 14 Dec 2006 09:59:28 GMT
I have did yet another try,now on windows machine .
The same problem!
Here are the steps to reproduce :
[1] Do a regular (vanilla) installation of tomcat (Linux and Windows i have
already tried) .
[2] Setup ssl:
Uncomment the ssl setup in server.xml create a key with the following:
%JAVA_HOME%\bin\keytool -genkey -alias tomcat -keyalg RSA
or
$JAVA_HOME/bin/keytool -genkey -alias tomcat -keyalg RSA
(taken from tomcat's manual)
add the keystorePass and keystoreFile to server.xml
start the tomcat and test if the ssl works .
[3] Try this in browser:
http://localhost:8443 (note the http not the https)
or
telnet localhost 8443
Note that the telnet should be done from a terminal that can show binary
output.
(rxvt,xterm will NOT do,for me gnome terminal and cmd on windows worked).
in the telnet session you will get a connection type something ,hit ENTER
and you will get
strange bits in the response.
If you are doing this in browser it will just try to download those bits
(Mozilla) or show it
on the screen (IE).
I am pretty sure that this is NOT valid behaviour.
I have tried all this on :
tomcat 5.5.20
java 1.5.0_09
and
same tomcat
java 1.5.0_06
Both Linux and Windows .
Now I am pretty sure this is a tomcat problem ,not sure which versions.
I need somebody except me to reproduce this before asking developers.
Anybody?
Thanks.
P.S. Hassan could you please do this ?Just try it with firefox/ie and other
terminal?
Evgeny.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message