tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jim Reynolds" <jim.jreyn...@gmail.com>
Subject SSL Setup From Site
Date Wed, 13 Dec 2006 17:39:54 GMT
After creating a new Host, I now want to set up SSL on it. Following
the docs I did the following:

1) create keystore
E:\Tomcat\bin\DEVKEY>keytool -genkey -alias tomcat -keyalg RSA -keystore E:/Tomc
at/bin/DEVKEY/devKeystore
answered questions.

2) made sure passwords were same. (changeit)

3) uncomment out the
<Connector
           port="443" minProcessors="5" maxProcessors="75"
           enableLookups="true" disableUploadTimeout="true"
           acceptCount="100" debug="0" scheme="https" secure="true"
           keystoreFile="E:/Tomcat/bin/DEVKEY/devKeystore"
           keystorePass="changeit"
           clientAuth="false" sslProtocol="TLS"/>
// added above keystore location.

4) restarted tomcat, but I do not get ssl?

http://devsite (still happy)
https://devsite (canot connect)

I am running all local here, no external hassles. Now while reading
the docs for nth time, I am wondering if I need to create a
certificate or not? It is hard to tell as they roll into discussing
openSSL or verisign/Thawte.

Anyway, If I am missing a step here, please let me know,

Sincerely

---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message