tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Joel Klein" <jfklei...@gmail.com>
Subject Re: Tomcat listening on port but not responding to requests
Date Fri, 01 Dec 2006 17:19:25 GMT
Tim wrote:
>Is there a curses-based browser on the machines you could use via ssh?

Not that I know of.

>Can you try doing the same thing from the machines themselves--ssh
>in, then telnet localhost 8080?

Connecting via telnet on the machines themselves also doesn't work.

> The only other thing I can think of to check offhand is the firewall...

This is what I'm starting to strongly suspect.  I ran nmap against
these servers and it reported that the Tomcat port on one of them is
"filtered", but that the other one is open.  This seems consistent
with the results of telneting to them, the one that is reported
"filtered" times out, the one that is reported "open" telnet was able
to connect to, but the GET request itself timed out.  I checked ipfw
and ip6fw and the rule counts are zero except for the default "allow
anything" rule.  Is there other firewall software for the Mac that
could apply?

The odd thing that needs an explanation, if a firewall is responsible,
is that these machines were working fine.

This is starting to look less like a Tomcat-specific problem, but
nevertheless if anyone on this list has any helpful ideas I'd
appreciate the pointer.

-- 
Joel                             [Online at http://jfkbits.blogspot.com]

---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message