tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Leon Rosenberg" <rosenberg.l...@googlemail.com>
Subject Re: How to get User Access logs in tomcat
Date Wed, 13 Dec 2006 22:16:58 GMT
I think your valve definition misses some attributes:

         <Valve className="org.apache.catalina.valves.AccessLogValve"
                        directory="logs" prefix="access_webapp." suffix=".log"
                        pattern="common"/>

regards
Leon

On 12/13/06, Jason Friedman <ysonglist@gmail.com> wrote:
> I've tried to get user access logs like:
>
> ---
>
> 127.0.0.1 - - [19/Oct/2006:12:38:09 +0800] "GET / HTTP/1.1" 302 - 0.240 -
> 127.0.0.1 - - [19/Oct/2006:12:38:09 +0800] "GET / HTTP/1.1" 302 - 0.243 -
> 127.0.0.1 - - [19/Oct/2006:12:38:11 +0800] "GET
> /secure/Setup!default.jspa HTTP/1.1" 302 - 1.732
> 39F9C7F048F7F060A4B9883A7348082D
> ---
>
>
>
> I cannot find such logs in the logs/ directory, what configuation should I
> do to have it appears? What plugin should I have? Thanks.
> I've tried to add the following to the server.xml files, but it doesn't work
>
> <Valve className="org.apache.catalina.valves.AccessLogValve"
> pattern="%h %l %u %t &quot;%r&quot; %s %b %T %S" resolveHosts="false"
> />
>
>
> Jason.
>
>

---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message