tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bijan Vakili" <Bijan.Vak...@cryptologic.com>
Subject Apache SSL + mod_jk
Date Fri, 15 Dec 2006 20:04:34 GMT
Hi,

 

I've been trying to get mod_jk to work where

1)       Users connect to the Apache server via HTTPS

2)       All requests are proxied to Tomcat via mod_jk using AJP1.3

 

I have been able to get this to work with HTTP.  However, when I switch
to using HTTPS, the HTML content returned by Tomcat through mod_jk
always contains HTTP (hence there will be broken links everywhere). 

 

Does anyone know how to get this to work?  Is there a sample
configuration I can look at that would do the same thing?

 

 

Thanks in advance,

 

 

Bijan Vakili

Senior Software Developer

 

Cryptologic Inc. 

55 St-Clair W, 3rd floor, Toronto, Ontario, M4V 2Y7
Phone 416.545-1455 Ext 5892
E-Mail: bijan.vakili@cryptologic.com
<mailto:bijan.vakili@cryptologic.com> 

SKYPE: bijanvakili 

This message, including any attachments, is confidential and/or
privileged and contains information intended only for the person(s)
named above. Any other distribution, copying or disclosure is strictly
prohibited. If you are not the intended recipient or have received this
message in error, please notify us immediately by reply email and
permanently delete the original transmission from all of your systems
and hard drives, including any attachments, without making a copy.

 


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message