tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bijan Vakili" <Bijan.Vak...@cryptologic.com>
Subject FW: Connectors and SSL
Date Thu, 14 Dec 2006 17:09:54 GMT
Hi,

 

I'm trying to enable an SSL connector on Tomcat.  The certificate files
I'm using are shared with my Apache2 web server (see below).  I'm using
the following APR configuration:

 

<Connector port="8443" maxHttpHeaderSize="8192"

               maxThreads="150" minSpareThreads="25"
maxSpareThreads="75"

               enableLookups="false" disableUploadTimeout="true"

               acceptCount="100" scheme="https" secure="true"

               SSLEngine="on"

               SSLCertificateFile="/etc/apache2/ssl.crt/server.crt"

               SSLCertificateKeyFile="/etc/apache2/ssl.key/server.key"
/>

 

However, the connection keeps timing out whenever I attempt to test it
via HTTPS.  Strangely, I can connect to this port using HTTP (which I
don't want).

 

Can anyone tell me how I can fix this?

 

 

Thanks in advance,

 

Bijan Vakili

Senior Software Developer

 

Cryptologic Inc. 

55 St-Clair W, 3rd floor, Toronto, Ontario, M4V 2Y7
Phone 416.545-1455 Ext 5892
E-Mail: bijan.vakili@cryptologic.com
<mailto:bijan.vakili@cryptologic.com> 

SKYPE: bijanvakili 

This message, including any attachments, is confidential and/or
privileged and contains information intended only for the person(s)
named above. Any other distribution, copying or disclosure is strictly
prohibited. If you are not the intended recipient or have received this
message in error, please notify us immediately by reply email and
permanently delete the original transmission from all of your systems
and hard drives, including any attachments, without making a copy.

 


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message