tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Zachary Wiener <zwie...@caci.com>
Subject Re: Request for WMV file to machine name doesn't work
Date Mon, 06 Nov 2006 13:54:42 GMT
I still have the problem even if I do add the MIME type.  And the problem 
occurs only when I am on the same machine as where Tomcat is installed, 
and I request the file using http://<machine name:8080> as opposed to 
http://localhost:8080.  In any case, to specify the correct mime type 
modify <tomcat root>/conf/web.xml and add the following:

    <mime-mapping>
        <extension>wmv</extension>
        <mime-type>video/x-ms-wmv</mime-type>
    </mime-mapping>

You might have to restart tomcat afterwards.





Zeina Aoun <zn_aoun@yahoo.com> 
11/03/2006 01:48 PM
Please respond to
"Tomcat Users List" <users@tomcat.apache.org>


To
Tomcat Users List <users@tomcat.apache.org>
cc

Subject
Re: Request for WMV file to machine name doesn't work






Hi!

I am having the same problem and had posted my question earlier.

I have installed 2 media files 1 is .wmv and the other is .rmvb, both of 
the files open as text in the browser for some starnge reason.

Ppl told me to set the correct mime in web.xml, but I am just a basic 
user, I did not understand what to do.

Can u please tell me how u set the correct mimie in web.xml?

Thank u


----- Original Message ----
From: Zachary Wiener <zwiener@caci.com>
To: users@tomcat.apache.org
Sent: Friday, November 3, 2006 8:23:30 AM
Subject: Request for WMV file to machine name doesn't work


Hello.  I have Tomcat 5.0.28 installed on my Windows XP machine.  Under 
webapps I have a website installed, and under the website I have a *.wmv 
file installed.  If I access this file through Internet Explorer as 
http://<machine_name>:8080/mysite/test.wmv, the file does not open in 
media player, but displays as text.  I have made sure that the web.xml has 

the mime type defined.  If I access the file as 
http://localhost:8080/mysite/test.wmv, the file will be played in media 
file.  If I access the file from a different machine and access as 
http://<machine_name>:8080/mysite/test.wmv, the file will be played in 
media player.  My question is, if I am logged into my machine and I access 

the file using the machine name, why is it displayed as text, but 
localhost works?  Thank you.




Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message