tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From maxt <maxtel...@yahoo.com.au>
Subject Locale difference with Console and Windows Service
Date Sat, 04 Nov 2006 00:43:07 GMT

I am using Windows XP, Tomcat 5.5.17, JRE 1.5.0_08. I am in Australia. To
test localization, my Windows Region is set to English, US. 

When using the Console, tomcat5.exe, my localization files work correctly,
returning the Locale, en_US. 

When using Windows Services, the Locale returned is en.AU with the same code
and Region still set to English, US. 

In the Services I am using a Classpath command: C:\Program
Files\BMJ\Tomcat\bin\bootstrap.jar and Java Options: 
-Dcatalina.base=C:\Program Files\BMJ\Tomcat 
-Dcatalina.home=C:\Program Files\BMJ\Tomcat 

Any help explaining how to get the default Locale using Services would be
appreciated. I do not want to set the Locale, but to get and apply my users
default Locale using Services. 

The same problem applies to the use of the Robot class used for sending
keystrokes. OK with Console, no response or error with Services. 

Max

-- 
View this message in context: http://www.nabble.com/Locale-difference-with-Console-and-Windows-Service-tf2572041.html#a7170215
Sent from the Tomcat - User mailing list archive at Nabble.com.


---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message