tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rainer Jung <rainer.j...@kippdata.de>
Subject Re: Solaris 10 Apache 2 Tomcat mod_jk
Date Wed, 22 Nov 2006 21:50:57 GMT
ben short schrieb:
> Rainer,
> 
> Running the svcadm enable apache2 command without the LoadModule
> starts apache correctly.
> 
> Someone else pointed out that using svcs -xv will show me the logfile
> I need to look at, and I see the following error..
> 
> [ Nov 22 19:35:06 Method "start" exited with status 1 ]
> [ Nov 22 19:35:06 Executing start method
> ("/lib/svc/method/http-apache2 start") ]
> Syntax error on line 275 of /etc/apache2/httpd.conf:
> Cannot load /usr/apache2/libexec/mod_jk.so into server: ld.so.1:
> httpd: fatal: /usr/apache2/libexec/mod_jk.so: open failed: No such
> file or directory

Nevertheless it would be faster to first debug using apachectl. The same
messages will directly appear on your terminal windows when starting
apache via apachectl.

> It seems that pkg-get -i ap2_mod_jk installed it to
> /opt/csw/apache2/libexec/.
> 
> So i changed the LoadModule line to
> 
> LoadModule jk_module /opt/csw/apache2/libexec/mod_jk.so
> 
> But I get the following error when trying to start apache.
> 
> [ Nov 22 20:31:44 Executing start method
> ("/lib/svc/method/http-apache2 start") ]
> Syntax error on line 275 of /etc/apache2/httpd.conf:
> API module structure `jk_module' in file
> /opt/csw/apache2/libexec/mod_jk.so is garbled - perhaps this is not an
> Apache module DSO?
> [ Nov 22 20:31:44 Method "start" exited with status 1 ]

So your module file is either corrupt, or for the wrong version of
apache (1.3, 2.0, 2.2).

> On 11/22/06, Rainer Jung <rainer.jung@kippdata.de> wrote:
>> Hi Ben,
>>
>> before you integrate your apache into Solaris SMF (service management
>> facility) you should first check, if apache does really work.
>>
>> So begin by using the usual apachectl script and once you debugged your
>> configuration and the functionality looks good, you can use SMF to
>> reliably start the service.
>>
>> Adding only the LoadModule line in the Apache config is not enough. You
>> need to read the online documentation of tomcat connectors, especially
>> the pages about apache configuration and also about workers.properties.
>>
>> Regards,
>>
>> Rainer
>>
>> ben short wrote:
>> > Hi,
>> >
>> > Sorry if that this is a bit off topic but i figured someone might have
>> > some experience.
>> >
>> > I'm trying to get Apache 2 to use mod_jk in a Solaris 10 Zone. I have
>> > installed the ap2_mod_jk package from blastwave with no errors. I
>> > added the following line to the correct httpd.conf
>> >
>> > LoadModule jk_module libexec/mod_jk.so
>> >
>> > And then try to start apache using
>> >
>> > svcadm enable apache2
>> >
>> > I then do svcs and it shows the following
>> >
>> > maintenance    19:35:06 svc:/network/http:apache2
>> >
>> > I have check the logfiles but nothing is being written to them.
>> >
>> > The output from uname -a is
>> >
>> > SunOS arachne 5.10 Generic_Patch_118844-30 i86pc i386 i86pc
>> >
>> > Has anyone tried to do this?
>> >
>> > Regards
>> >
>> > Ben

---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message