tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Lars Nielsen Lind <...@tidtilforandring.dk>
Subject SEVERE: Error loading WebappClassLoader
Date Thu, 16 Nov 2006 08:50:22 GMT
I get this err msg when I am starting tomcat 5.5.20:

2006-11-16 09:22:02 org.apache.catalina.core.ApplicationContext log
INFO: Marking servlet CewolfServlet as unavailable
2006-11-16 09:22:02 org.apache.catalina.core.ApplicationContext log
SEVERE: Error loading WebappClassLoader
  delegate: false
  repositories:
    /WEB-INF/classes/
----------> Parent Classloader:
org.apache.catalina.loader.StandardClassLoader@c8f6f8
 de.laures.cewolf.CewolfRenderer
java.lang.ClassNotFoundException: de.laures.cewolf.CewolfRenderer
    at 
org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1355)
    at 
org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1201)
    at 
org.apache.catalina.core.StandardWrapper.loadServlet(StandardWrapper.java:1034)
    at 
org.apache.catalina.core.StandardWrapper.load(StandardWrapper.java:932)
    at 
org.apache.catalina.core.StandardContext.loadOnStartup(StandardContext.java:3951)
    at 
org.apache.catalina.core.StandardContext.start(StandardContext.java:4225)
...


My server.xml:

<Host name="192.168.1.232" appBase="webapps" unpackWARs="true" 
autoDeploy="true" xmlValidation="false" xmlNamespaceAware="false">
    <Context path="/" debug="0" docBase="application1" reloadable="true">
    </Context>
</Host>


I have tried with path="" and with 
appBase="/opt/apache-tomcat-5.5.20/webapps/application1" and with 
docBase="/opt/apache-tomcat-5.5.20/webapps/application1".


Any solutions?

Thanks,

Lars Nielsen Lind



---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message