tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Assaf Flatto <as...@atelis.net>
Subject Re: replication not working
Date Mon, 06 Nov 2006 15:27:34 GMT
my bad i forgot to add the <Cluster> definitions of my server.xml


<Cluster className="org.apache.catalina.cluster.tcp.SimpleTcpCluster" 
managerClassName="org.apache.catalina.cluster.session.D
                                         
expireSessionsOnShutdown="false" useDirtyFlag="true">
    <Membership 
className="org.apache.catalina.cluster.mcast.McastService" 
mcastAddr="228.0.0.4"
                                                 mcastPort="45564" 
mcastFrequency="500" mcastDropTime="3000"/>
    <Receiver 
className="org.apache.catalina.cluster.tcp.ReplicationListener" 
tcpListenAddress="auto"
                                                 tcpListenPort="4001" 
tcpSelectorTimeout="100" tcpThreadCount="25"/>
    <Sender 
className="org.apache.catalina.cluster.tcp.ReplicationTransmitter" 
replicationMode="pooled"/>
    <Valve className="org.apache.catalina.cluster.tcp.ReplicationValve" 
filter=".*\.gif;.*\.js;.*\.jpg;.*\.htm;.*\.html;.
    <Deployer 
className="org.apache.catalina.cluster.deploy.FarmWarDeployer" 
tempDir="/tmp/temp/"
                                            deployDir="/tmp/deploy/" 
watchDir="/tmp/listen/" watchEnabled="false"/>
</Cluster>

thanks

Assaf

Assaf Flatto wrote:
> Hello
>
> I have 3 servers with tomcat 5.0.30 , and i want to run them with data 
> replication .
> I manage to see the servers coming up and i can see in the log the 
> other servers identifying the other members of the cluster , however 
> when starting to test the replication between servers - there is non .
>
> Server 1 :
> 2006-11-06 18:04:44,954 [Cluster-MembershipReceiver] INFO  
> org.apache.catalina.cluster.tcp.SimpleTcpCluster  - Replication member 
> added:org.apache.catalina.cluster.mcast.McastMember[tcp://172.31.1.1:4001,172.31.1.1,4001,

> alive=42788]
>
> Server 2:
> 006-11-06 18:04:46,464 [Cluster-MembershipReceiver] INFO  
> org.apache.catalina.cluster.tcp.SimpleTcpCluster  - Replication member 
> added:org.apache.catalina.cluster.mcast.McastMember[tcp://172.31.1.2:4001,172.31.1.2,4001,

> alive=2]
>
>
> I can not upgrade to tomcat 5.5 so an answer along those lines is not 
> helpful .
>
> anyone got an idea as to what can be the cause of this ?
>
> Assaf
>
> ---------------------------------------------------------------------
> To start a new topic, e-mail: users@tomcat.apache.org
> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
> For additional commands, e-mail: users-help@tomcat.apache.org
>

---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message