tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rainer Jung <rainer.j...@kippdata.de>
Subject Re: Webapps that run on 5.0.28 but not 5.5.x?
Date Wed, 01 Nov 2006 19:04:09 GMT
Yes, binary compatibility should be OK. But most webapps have JSPs and
you are soon in the area of source code compatibility:

http://java.sun.com/javase/technologies/compatibility.jsp

I only wanted to indicate, that it might be better to migrate in two
steps, to keep the two possible reasons for trouble separate, especially
when arguing with your webapp supplier.

Regards,

Rainer

Glen Mazza schrieb:
> Yes, thanks for the reminder.  That's also something I need to keep in
> mind, as my installation guide says to load JRE 1.4.2, and I'm using
> 5.0.  But again, I'd like to say that 1.4.2-compiled class files
> *should* be able to run on a 5.0 JRE.  (I know if you recompile the
> source files--which I don't have access to anyway--and have
> 1.4.2-specific coding such as variables called "enum", that would create
> problems.)  But I suspect this would be less of a given than having a
> 5.0.28-able application be able to run on 5.5.20.
> 
> Thanks,
> Glen
> 
> Rainer Jung wrote:
> 
>> Apart from the changes in suggested deployment strategies and ressourec
>> definitions there's something to be careful:
>>
>> Upgrading to TC 5.5 and upgrading from Java 1.4 to Java 5 are two
>> different things. As long as you do only the first, chances are good,
>> that you get the webapp to run without code changes.
>>
>> An upgrade to Java 5 should be tried only after you get the webapp to
>> run under TC 5.5 with Java 1.4.
>>
>> Regards,
>>
>> Rainer
>>
>> Glen Mazza schrieb:
>>  
>>
>>> Hello,
>>>
>>> Question:  How common is it for a webapp to be able to run on Tomcat
>>> 5.0.28 but *not* 5.5.20?
>>>
>>> For the installation of a commerical web application that calls for
>>> installation of Tomcat 5.0.28, I'm inclined to just go ahead and use the
>>> 5.5 series of servlet containers.  Customer support is concerned that
>>> Tomcat 5.5 will not work (or at least has not been tested on the new
>>> version).  My thinking is that:
>>>
>>> 1.) Both containers implement the same specifications, so their
>>> development team would *really* have to be coding obscurely, bending
>>> over backwards to try to trip up the 5.5 servlet container, to be able
>>> to manage to build a webapp that will run on 5.0.28 but not 5.5.20.
>>>
>>> 2.) Further, it would require an extremely talented development team to
>>> be able to create a webapp that will run on 5.0.28 but not 5.5.20, but
>>> paradoxically, if they had that level of talent they would *not* build
>>> an application anyway that will work on 5.0.28 but not 5.5.20.
>>>
>>> Is my logic here correct or faulty?  To what degree is "This webapp will
>>> work on 5.0.28 but not 5.5.20" an old wives' tale?
>>>
>>> Thanks,
>>> Glen
>>>
>>>
>>> ---------------------------------------------------------------------
>>> To start a new topic, e-mail: users@tomcat.apache.org
>>> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
>>> For additional commands, e-mail: users-help@tomcat.apache.org
>>>   
>>
>> ---------------------------------------------------------------------
>> To start a new topic, e-mail: users@tomcat.apache.org
>> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
>> For additional commands, e-mail: users-help@tomcat.apache.org
>>
>>
>>  
>>
> 
> 
> ---------------------------------------------------------------------
> To start a new topic, e-mail: users@tomcat.apache.org
> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
> For additional commands, e-mail: users-help@tomcat.apache.org

---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message