tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Edoardo Panfili <edoa...@aspix.it>
Subject Re: haaving trouble html in tomcat 5.5.20
Date Wed, 01 Nov 2006 18:26:53 GMT
Zeina Aoun ha scritto:
> I am having trouble with html in tomcat. I am using the Apache Tomcat 5.5.20 Server
>  
> The problem is hard to describe. I am trying to enable some video clip files to be downloaded
by users, but unfortunatley instead of downloading it opens up the garbage text on the webpage,
just like if u try to open a media file in notepad or wordpad. It does not allow to download
the media files.
>  
> But when I try running the html page outside tomcat or in another server, it opens up
perfectly.

It seems that tomcat doesn't set up the proper mime type of your media 
files, the error is not in the html page.

I think that you can take a look at $TOMCAT/conf/web.xml and set up the 
proper mime type, in my web.xml there is no mapping for rmvb or wmv.

loocking in mime.types of my linux machine:
for wmv the mime type is video/x-ms-wmv

Edoardo


>  
>  
> I am using .rmvb and .wmv format clips.
>  
>  
> I am using this type of basic coding.
>  
> <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
> "http://www.w3.org/TR/xhtml1/DTD/xhtml1 - transitional.dtd">
> <html xmlns="http://www.w3.org/1999/xhtml">
> 
> <html>
>     <head>
>         <title> download video</title>
>     </head>
>      
>          
>         <br><br><br>
>          
>         <a href="video1.rmvb">  Clip1 </a>
>        <br><br>
>         <a href="video2.wmv"> Clip2 </a>
>     < div> 
> 
> </html>
>  
>  
> Thank u
> 
> 


-- 
edoardo@aspix.it
AIM: edoardopn
Jabber: edoardopa@talk.google.com
tel:075 9142766

---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message