tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Darek Czarkowski <dczarkow...@infinitesource.ca>
Subject Re: Unable to read TLD "META-INF/c.tld" from JAR file
Date Wed, 01 Nov 2006 20:02:43 GMT
On Wed, 2006-11-01 at 20:05 +0200, Vasiliy Keretsman wrote:
> Not while Tomcat is running.
> I am aware of the work folder. It happens when Tomcat starts with
> empty work folder.
> 
> Just upgraded to J2SDK1.4.2_12 - the same result
> 
> On 01/11/06, Darek Czarkowski <dczarkowski@infinitesource.ca> wrote:
> > Are you deleting the content of work folder while tomcat is running?
> > Don't!
> >
> > "Work Folder: Automatically generated by Tomcat, this is where Tomcat
> > places
> > intermediate files (such as compiled JSP files) during it's work. If you
> > delete this directory while Tomcat is running you will not be able to
> > execute JSP pages."
> >
> > --
> > Darek Czarkowski
> > www.infinitesource.ca
> > darekc at infinitesource dot ca
> >
> >
> >  On Wed, 2006-11-01 at 19:03 +0200, Vasiliy Keretsman wrote:
> > > Hello!
> > >
> > > Strange problem appears with Tomcat. It can't read the tlds from JAR
> > > file (standard.jar).
> > > org.apache.jasper.JasperException: Unable to read TLD "META-INF/c.tld"
> > > from JAR file
> > >
> > > It happens only once when Tomcat/work folder is empty. After page
> > > refresh everything goes well.
> > >
> > > Details:
> > > 1. Tomcat 5.0.28
> > > 2. J2SDK 1.4.2_02
> > > 3. standard.jar is not corrupted and includes all tlds in META-INF
> > > 4. WEB-INF/lib doesn't contain jsp-api.jar
> > >
> > > Any ideas?
> > >
> > > Thanks in advance
> > >
> > > Best regards,
> > > Vasiliy
> > >
> > > ---------------------------------------------------------------------
> > > To start a new topic, e-mail: users@tomcat.apache.org
> > > To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
> > > For additional commands, e-mail: users-help@tomcat.apache.org
> > >
> >
> >
> >
> > ---------------------------------------------------------------------
> > To start a new topic, e-mail: users@tomcat.apache.org
> > To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
> > For additional commands, e-mail: users-help@tomcat.apache.org
> >
> >
> 
> ---------------------------------------------------------------------
> To start a new topic, e-mail: users@tomcat.apache.org
> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
> For additional commands, e-mail: users-help@tomcat.apache.org
> 

Should have tried google first, if you did, you should provide more
details. Here is what searching for your problem comes up with.

http://saloon.javaranch.com/cgi-bin/ubb/ultimatebb.cgi?
ubb=get_topic&f=50&t=007815

Is this similar to your problem? Or perhaps you are deploying jsp-
api.jar with your application? there is number of reasons this could be
happening.

-- 
Darek Czarkowski
www.infinitesource.ca
darekc at infinitesource dot ca


---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message