tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Marco Aurélio S. Silva" <marcoaurelio...@gmail.com>
Subject Re: Problem Deploying an Application
Date Thu, 19 Oct 2006 18:16:31 GMT
Hi Li,

I checked and the javax/servlet/http/HttpServletRequest is in the jar, I had
try to change the jar and nothing happens...

I write a simple test page and everything run correctly...

I use the same war file in other server, and it deploys and run, only on
this server I'm having problem.... I try to deploy the probe application and
the same problem occurs..

Thanks,

-- 
Marco Aurélio S. Silva
marcoaureliocom@gmail.com


2006/10/19, Li <ampyx.li@gmail.com>:
>
> If so, I dont see any problem for your tomcat since some webapp can be
> deployed without any problem.
>
> Can you check:
> 1. there is javax/servlet/http/HttpServletRequest in your servlet jar
> (under
> common), do not place it in your WEB-INF/lib
> 2. you can write a very simple test page as home page for the webapp you r
> going to deploy, see if there is any problem
>
> wish it helps, good luck
>
> On 10/19/06, Marco Aurélio S. Silva <marcoaureliocom@gmail.com> wrote:
> >
> > The both are ok! I have some applications running well.... and some give
> > me
> > this problem
> >
> >
> >
> > 2006/10/19, Li <ampyx.li@gmail.com>:
> > >
> > > It looks like servlet jar can not be found, if your class path setting
> > is
> > > ok, make sure the permission is ok
> > >
> > >
> > > On 10/19/06, Marco Aurélio S. Silva <marcoaureliocom@gmail.com> wrote:
> > > >
> > > > Hi folks,
> > > >
> > > > I'm trying to deploy an application on my Tomcat 5.5.9 under a
> Windows
> > > > 2003
> > > > Server with JVM 1.5.0_04, and get the following stack error:
> > > >
> > > > 19/Out/2006 11:02:13
> > org.apache.catalina.core.StandardWrapperValveinvoke
> > > > SEVERE: Servlet.service() for servlet HTMLManager threw exception
> > > > java.lang.NoClassDefFoundError:
> javax/servlet/http/HttpServletRequest
> > > > at
> > > >
> > >
> >
> org.apache.commons.fileupload.servlet.ServletRequestContext.getContentType
> > > > (
> > > > ServletRequestContext.java:72)
> > > > at org.apache.commons.fileupload.FileUploadBase.parseRequest(
> > > > FileUploadBase.java:290)
> > > > at org.apache.commons.fileupload.FileUploadBase.parseRequest(
> > > > FileUploadBase.java:268)
> > > > at org.apache.catalina.manager.HTMLManagerServlet.doPost(
> > > > HTMLManagerServlet.java:157)
> > > > at javax.servlet.http.HttpServlet.service(HttpServlet.java:709)
> > > > at javax.servlet.http.HttpServlet.service(HttpServlet.java:802)
> > > > at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(
> > > > ApplicationFilterChain.java:252)
> > > > at org.apache.catalina.core.ApplicationFilterChain.doFilter(
> > > > ApplicationFilterChain.java:173)
> > > > at org.apache.catalina.core.StandardWrapperValve.invoke(
> > > > StandardWrapperValve.java:213)
> > > > at org.apache.catalina.core.StandardContextValve.invoke(
> > > > StandardContextValve.java:178)
> > > > at org.apache.catalina.authenticator.AuthenticatorBase.invoke(
> > > > AuthenticatorBase.java:482)
> > > > at org.apache.catalina.core.StandardHostValve.invoke(
> > > > StandardHostValve.java
> > > > :126)
> > > > at org.apache.catalina.valves.ErrorReportValve.invoke(
> > > > ErrorReportValve.java
> > > > :105)
> > > > at org.apache.catalina.core.StandardEngineValve.invoke(
> > > > StandardEngineValve.java:107)
> > > > at org.apache.catalina.connector.CoyoteAdapter.service(
> > > CoyoteAdapter.java
> > > > :148)
> > > > at org.apache.coyote.http11.Http11Processor.process(
> > Http11Processor.java
> > > > :856)
> > > > at
> > > >
> > > >
> > >
> >
> org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.processConnection
> > > > (Http11Protocol.java:744)
> > > > at org.apache.tomcat.util.net.PoolTcpEndpoint.processSocket(
> > > > PoolTcpEndpoint.java:527)
> > > > at org.apache.tomcat.util.net.LeaderFollowerWorkerThread.runIt(
> > > > LeaderFollowerWorkerThread.java:80)
> > > > at org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(
> > > > ThreadPool.java:684)
> > > > at java.lang.Thread.run(Unknown Source)
> > > >
> > > > I was looking for how to solve it, and find that it seems to be a
> > > problem
> > > > on
> > > > the ClassLoader, and only a new installation of the Tomcat solve it!
> > Is
> > > > that
> > > > true or there is another way to solve it?
> > > >
> > > > I checked the servlet-api.jar and it's ok!
> > > >
> > > > Thanks,
> > > >
> > > > --
> > > > Marco Aurélio S. Silva
> > > > marcoaureliocom@gmail.com
> > > >
> > > >
> > >
> > >
> > > --
> > > When we invent time, we invent death.
> > >
> > >
> >
> >
> > --
> > Marco Aurélio S. Silva
> > marcoaureliocom@gmail.com
> >
> >
>
>
> --
> When we invent time, we invent death.
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message