tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From <Gunnar.Bost...@tietoenator.com>
Subject SV: Problem with filter and calling Perl-script with Tomcat 5.5.20
Date Thu, 19 Oct 2006 08:46:24 GMT
Hi,

That is odd because I have the following problems:

1) When I post an ordinary form, not a multipart, no parameters will be sent to the Perl script.

2) When I post a multipart form I get everything OK, but not a parameter that my servlet filter
introduced.

We have done some changes now to the CGIServlet code so I think it works for our case.
I intend to send it to the list when we have done some more testing.

Regards
Gunnar


> -----Ursprungligt meddelande-----
> Från: Mark Thomas [mailto:markt@apache.org] 
> Skickat: den 19 oktober 2006 03:04
> Till: Tomcat Users List
> Ämne: Re: Problem with filter and calling Perl-script with 
> Tomcat 5.5.20
> 
> Gunnar.Bostrom@tietoenator.com wrote:
> > Hi,
> > 
> > We need the fix for multipart forms introduced in 5.5.20 so 
> go back to version 5.5.17 is not an option.
> > 
> > But the problem seems even worse because forms POST'ed does 
> not work with the CGI module! 
> > 
> > We have to many Perl-scripts that use the CGI-module so 
> rewriting them to read directly from stdin is not doable.
> > 
> > The following Perl script taken from a tutorial on the net 
> works if the form is sent with GET but not with POST!
> 
> I have tested the exact code you posted with the latest 5.5.x 
> code (CGI servlet unchanged since 5.5.20) on both Windows and 
> Linux and as expected it works correctly for both GET and POST.
> 
> I am at a loss as to what could be wrong with your system. If 
> I were in your position I would set up remote debugging and 
> start stepping though the code to see exactly what is going on.
> 
> Mark
> 
> ---------------------------------------------------------------------
> To start a new topic, e-mail: users@tomcat.apache.org To 
> unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
> For additional commands, e-mail: users-help@tomcat.apache.org
> 
> 

---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message