tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Robbert <robbert.ouweh...@gmail.com>
Subject CSS not being used when a Servlet is involved
Date Fri, 27 Oct 2006 15:42:57 GMT

Hi, I have the following problem:

If I include the Servlet using the jsp:include tag and if the web.xml file
is configured correctly, it will invoke the Servlet, but the CSS won't load.
If I change the URL pattern, the Servlet won't be invoked (with a "Resource
unavailable" error) but the CSS is rendered.

Here's where the files are:

$CATALINA_HOME/webapps/ROOT/doc/o23/index.jsp (deze jsp file roept dus de
StatistiekServlet aan)
$CATALINA_HOME/webapps/ROOT/doc/o23/StatistiekServlet
$CATALINA_HOME/webapps/ROOT/WEB-INF/classes/o23/StatistiekServlet
$CATALINA_HOME/webapps/ROOT/WEB-INF/classes/StatistiekServlet

(Yes, I have three locations for the statistics servlet. I don't know where
to place it!)

Here's the code for the servlet in web.xml

	<servlet>
	  <servlet-name>StatistiekServlet</servlet-name>
	  <servlet-class>StatistiekServlet</servlet-class>
	</servlet>
	
	<servlet-mapping>
	  <servlet-name>StatistiekServlet</servlet-name>
	  <url-pattern>/</url-pattern>
	</servlet-mapping><



I always have this problem with Servlets. Is there any way to use CSS (and
similar things...) with Servlets without too much trouble (like, changing
some configuration settings)?

Thanks in advance! (Yes, I've searched but I couldn't find a helping
answer).
-- 
View this message in context: http://www.nabble.com/CSS-not-being-used-when-a-Servlet-is-involved-tf2521410.html#a7032844
Sent from the Tomcat - User mailing list archive at Nabble.com.


---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message