tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Courcy <michael.cou...@gmail.com>
Subject Re: Problems configuring a <Context path="xx"> using Apache/Tomcat
Date Tue, 24 Oct 2006 21:29:20 GMT
Hi
Can you explain where you define context.xml ?
Here is a fragment of
http://tomcat.apache.org/tomcat-5.5-doc/config/context.html
path : [...] The value of this field must not be set except when 
statically defining a Context in server.xml, as it will be infered from 
the filenames used for either the .xml context file or the docBase.

Mic


René Schade a écrit :
> Hi List,
>
>  
>
> I'm running Apache 2.0, Tomcat 5.5.17, jdk 1.5
>
>  
>
> I'm upgrading from Apache 1.3 Tomcat 3.* jdk 1.4
>
>  
>
> In my Apache log file I have the following:
>
>  
>
>         JkMount /manager* foo
>
>         JkMount /servlets/* foo
>
>  
>
> The manager application works fine, when typing the URL
>
>  
>
> http://website/manager/html 
>
>  
>
> Everything is ok, the manager application is launched.
>
>  
>
> Now I'm trying to install an application on the path /servlets/myapplication. The Context
file looks like this:
>
>  
>
> <Context  reloadable="true" path="/servlets/myapplication/" docBase="${catalina.home}/home/schade/myapplication/"
debug="5" allowoverride="true">
>
>                   <Valve className="org.apache.catalina.valves.AccessLogValve"
>
>                     prefix="kvisremote_by_schade." suffix=".txt"
>
>                                  pattern="common"/>
>
> </Context>
>
>  
>
> Typing a URL like http://website/servlets/myapplication/testfile.html does not trigger
this context. I've made a similar Valve for the manager-application, and here every request
to the manager Context is logged. Logging the <host> verifies that requests sent to
http://website/servlets/kvisremote are sent to the host, but it does not seam to know which
context to forward the request to.
>
>  
>
> I guess it has something to do with the path-attribute. A similar solution worked fine
on the old server...
>
>  
>
> I've been struggling with this for a while now, so any kinds of suggestions are appreciated.

>
>  
>
> Regards,
> René
>
>
>   


---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message