tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Smith <d...@cornell.edu>
Subject Re: error while running a webapp
Date Fri, 06 Oct 2006 12:08:04 GMT
A word of caution -- autoReconnect=true is more a hack than a solution.  
Recent experience of users in another list I'm on suggest it's really 
hit or miss whether it actually recovers a stale connection or not.

It's best in a design pattern to implement a connection pool and be sure 
to close connections as soon as possible -- from connection open to 
close within a single method call if possible.  If you're worried about 
the overhead of building and closing connections, calling close() on a 
pooled connection really just returns it to the pool.

As far as the OP's problem is concerned, some additional information 
like relevant log and code excerpts would be most helpful.  We really 
don't know that it's a db connection problem or something else.

--David

Hassan Schroeder wrote:

> On 10/5/06, Oliver Wagner <lists@wagner-www.de> wrote:
>
>>
>> I think the DB close the connection while the tomcat is running and I 
>> don't know (at my Connection-Pool) how to know when that happened.
>
>
> set
>   autoReconnect=true
> in your driver config, or catch the exception when the timeout occurs
> and retry connecting to see if it's a simple timeout/transient failure or
> something more  persistent.
>
> HTH!



---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message