tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rico <ras_k...@yahoo.com>
Subject Perfect, provided 'virgin' install on XP- ClassNotFoundException on 'used' 2K...
Date Fri, 13 Oct 2006 15:59:38 GMT
Hello Everyone,

On Windows 2000 where over the past couple of years I had installed Tomcat4 and Tomcat4.1,
running Tomcat5.0.28 as a service now gives:
==========================================
ERROR reading D:\jakarta-tomcat-5.0.28\conf\server.xml
At Line 24 /Server/Listener/ className=org.apache.catalina.mbeans.ServerLifecycleListener
debug=0 

Catalina.start: java.lang.ClassNotFoundException: org.apache.catalina.mbeans.ServerLifecycleListener
java.lang.ClassNotFoundException: org.apache.catalina.mbeans.ServerLifecycleListener
==========================================

I've been quite mad about this, I've got to admit. Trying to get Tomcat to work has gotten
in the way of
learning anything 'productive' yet. I've looked all over the place, and others have run into
this issue, but
nobody could offer a solution or people just ignored the query, and I wonder if it's because
it's too obvious
or they just couldn't reproduce it.
If I'm missing something very obvious here, I am sincerely sorry but I'm not seeing it yet
since yesterday.

The good news is that things Finally! worked fine when I thought of trying on XP on my other
hard disk
where Tomcat had never set foot. That helped me calm down a lot.. I mean, Matt Raible only
gave
SiteMesh a 10-mins test, didn't he? The pressure on me is what good will I ever be if I haven't
gotten
anything done in 24hours?!

Now.. this problem seems to be related to something about my Win2K PC, and probably my previous
installations of Tomcat, which I have removed by now, and/or my previous JDK's and JRE's.
But I don't know what, and was hoping that somebody here could shed some light on where I
should be looking and what I should be doing?
Thanks.

Rico.





---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message