tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dan Adams <...@ifactory.com>
Subject Response already committed
Date Tue, 03 Oct 2006 20:32:22 GMT
I'm getting a problem that appears to occur randomly. If I request the
same page in my webapp over and over most of the time it will come up
fine but sometimes tomcat won't return anything and I'll get a blank
page and this error in the log:

Oct 3, 2006 4:20:22 PM org.apache.jk.core.MsgContext action
INFO: Response already committed

It also happens for static files like stylesheets so sometimes you will
request a page and then the styles won't get loaded. Anyone have any
clues as to what this could be? I'm googling around and looking through
my tomcat book but haven't found an answer yet. I'm using tomcat 5.5
with the mod_jk connector and apache 2. Here is my server.xml:

<Server port="8005" shutdown="SHUTDOWN">
  <GlobalNamingResources>
    <Environment name="simpleValue" type="java.lang.Integer"
value="30"/>
    <Resource name="UserDatabase" auth="Container"
              type="org.apache.catalina.UserDatabase"
       description="User database that can be updated and saved"
           factory="org.apache.catalina.users.MemoryUserDatabaseFactory"
          pathname="conf/tomcat-users.xml" />
  </GlobalNamingResources>
  <Service name="Catalina">
    <Connector port="8080" />

    <!-- Define an AJP 1.3 Connector on port 8029 -->
    <Connector port="8029"
               enableLookups="false" redirectPort="8443"
protocol="AJP/1.3" />

    <!-- Define the top level container in our container hierarchy -->
    <Engine name="Catalina" defaultHost="localhost">
      <Realm className="org.apache.catalina.realm.UserDatabaseRealm"
             resourceName="UserDatabase"/>
      <Realm className="org.apache.catalina.realm.MemoryRealm" />
      <Host name="localhost" appBase="webapps" unpackWARs="true"
autoDeploy="true" />

      <!-- Define the default virtual host
           Note: XML Schema validation will not work with Xerces 2.2.
       -->

      <Host name="domain.company.com" appBase="hosts/domain" debug="0"
unpackWARs="true" autoDeploy="false">
        <Context path="" docBase="." />
      </Host>

    </Engine>

  </Service>

</Server>


-- 
Dan Adams
Senior Software Engineer
Interactive Factory
617.235.5857


---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message