tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "mast" <mas...@tyranz.com>
Subject Re: getContextPath
Date Tue, 31 Oct 2006 22:10:38 GMT
little correction it seem that if i put a directory in the same way as the 
ROOT directory tomcat use it instead of the other
exemple :
 /usr/local/tomcat5/webapps/users1/ROOT/test/test.jsp
 /usr/local/tomcat5/webapps/users1/test/test.jsp

tomcat use the second one (and their appear the ContextPath: /test )
is this the normal way of tomcat working? if so all is ok thanks for all
----- Original Message ----- 
From: "mast" <master@tyranz.com>
To: "Tomcat Users List" <users@tomcat.apache.org>
Sent: Tuesday, October 31, 2006 11:04 PM
Subject: Re: getContextPath


> Hmm well it seem i have made a mistake
> the server.xml is correct and my configuration under ROOT too but it seem 
> that if i put some file before the ROOT directory tomcat take that as the 
> defaut context?
> i explain :
> i have put like i said :
> appBase="/usr/local/tomcat5/webapps/users1"
> there i have create a ROOT directory 
> /usr/local/tomcat5/webapps/users1/ROOT/ (WEB-INF etc after the ROOT)
> but i had a WEB-INF and META-INF in the same directory as the ROOT too and 
> they seem to have been taken instead of the one in the ROOT one (is it 
> normal?)
> now all works fine sorry to have make you loose time.
>
>
>
> ----- Original Message ----- 
> From: "mast" <master@tyranz.com>
> To: "Tomcat Users List" <users@tomcat.apache.org>
> Sent: Tuesday, October 31, 2006 10:51 PM
> Subject: Re: getContextPath
>
>
>> >From: "Caldarale, Charles R" <Chuck.Caldarale@unisys.com>
>>>To: "Tomcat Users List" <users@tomcat.apache.org>
>>>Sent: Tuesday, October 31, 2006 10:37 PM
>>>Subject: RE: getContextPath
>>>Do you have a test.xml lurking around in conf/[engine]/[host] in one of
>>>them?  Would that test.xml have a <Context> element with a docBase
>>>pointing to ROOT/test?  If so, that's incorrect.
>>
>> each webapps is independant my app is the ROOT directory now i define 
>> host like that :
>> appBase="/usr/local/tomcat5/webapps/users1"
>> appBase="/usr/local/tomcat5/webapps/users2"
>> each one have their own ROOT directory
>> but for the actual problem   i dont have any test.xml file or anything 
>> else on engine (or elsewhere that i can see)
>> both the 5.5.20 and 5.5.17 are new tomcat installed exactly the same way 
>> no docbase or anything else that i can see
>>
>>
>> ---------------------------------------------------------------------
>> To start a new topic, e-mail: users@tomcat.apache.org
>> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
>> For additional commands, e-mail: users-help@tomcat.apache.org
>>
>>
>
>
> ---------------------------------------------------------------------
> To start a new topic, e-mail: users@tomcat.apache.org
> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
> For additional commands, e-mail: users-help@tomcat.apache.org
>
> 


---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message