tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jim Weir" <javaw...@hotmail.com>
Subject Apache Tomcat Connector
Date Tue, 05 Sep 2006 14:20:36 GMT
To all,

  My JK connector is working but I can't figure out how to forward to 
Tomcat.  How do I know?

In my Catalina log file it says,

INFO: JK2: ajp13 listening on /0.0.0.0:8009

I tried many modifications to the httpd-vhosts.conf below and can generate 
an error in the mod_jk.log by changing "worker1" to "worker", it generates 
this error,

[Tue Sep 05 10:09:56 2006] [12042:63168] [info]  jk_handler::mod_jk.c 
(1986): Could not find a worker for worker name=worker



In my httpd-vhosts.conf I have,

<VirtualHost *:80>
    ServerName www.mysite.org

   ServerAdmin 4@yahoo.com
   ServerAlias mysite.org.com  *.mysite.org.com
   DocumentRoot /usr/opt/tomcat/webapps/mysite/

   Alias / /usr/opt/tomcat/webapps/mysite

   JkMount /*.* worker
   JkMount /*/servlet/ worker

</VirtualHost>

It seems to me that there's something in the httpd-vhosts.conf but I'm 
really no positive that's the case...could it be the server.xml?

This is the entry I have in the server.xml,

<Host name="www.mysite.org" appBase="webapps"
       unpackWARs="true" autoDeploy="true"
       xmlValidation="false" xmlNamespaceAware="false">
</Host>

Thanks in advance for any advice,
Jim

_________________________________________________________________
Call friends with PC-to-PC calling -- FREE   
http://imagine-msn.com/messenger/launch80/default.aspx?locale=en-us&source=wlmailtagline


---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message