tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From gur...@resolution.com
Subject Failed authenticate() test ??
Date Tue, 12 Sep 2006 22:48:08 GMT
Hi,
We used to use tomcat4 and start using tomcat5(start using different DB also).
Basically I have copied server.xml (tomcat4) to server.xml(tomcat5) with
minimal
changes. Did same thing for web.xml files also.

Other two webapps work fine so far, but I am having problem to get running
third
one which uses <form method="POST"
action="j_security_check" name="security">
for authentication. When I tried to login I get below; It says first successful
and fails. Could not figure it out. I have tried to put REALM outside of the
HOST and inside HOST tag in server.xml but did not do any difference also.
Thanks for help.

My part of web.xml
---------------------------------------------------------------

<security-constraint>
                <web-resource-collection>
                        <web-resource-name>ULC
Access</web-resource-name>
                        <url-pattern>/client/*</url-pattern>
                        <url-pattern>/system/*</url-pattern>
                        <url-pattern>/db/*</url-pattern>
                </web-resource-collection>
                <auth-constraint>
                        <role-name>Administrator</role-name>
                        <role-name>Employee</role-name>
                        <role-name>Client</role-name>
                        <role-name>Manager</role-name>
                        <role-name>Consultant Manager</role-name>
                        <role-name>Employee Manager</role-name>
                        <role-name>Consultant</role-name>
                        <role-name>Manufacturer</role-name>
                </auth-constraint>
        </security-constraint>

        <login-config>
                <auth-method>FORM</auth-method>
                <realm-name>DB</realm-name>
                <form-login-config>
                       
<form-login-page>/jsp/login/index.jsp</form-login-page>
                       
<form-error-page>/jsp/login/error.jsp</form-error-page>
                </form-login-config>
        </login-config>




---------------------------------------------------------------
[30 Jun 2006 02:38:41,980] 106459 [http-8080-Processor23] DEBUG
org.apache.catalina.authenticator.AuthenticatorBase  - Security checking
request
POST /ulc/db/j_security_check
[30 Jun 2006 02:38:41,981] 106460 [http-8080-Processor23] DEBUG
org.apache.catalina.authenticator.FormAuthenticator  - Authenticating username
'APRESLEY'
[30 Jun 2006 02:38:42,049] 106528 [http-8080-Processor23] DEBUG
org.apache.catalina.authenticator.FormAuthenticator  - Authentication of
'APRESLEY' was successful
[30 Jun 2006 02:38:42,050] 106529 [http-8080-Processor23] DEBUG
org.apache.catalina.authenticator.FormAuthenticator  - Redirecting to original
'/ulc/db/Navigate'
[30 Jun 2006 02:38:42,050] 106529 [http-8080-Processor23] DEBUG
org.apache.catalina.authenticator.AuthenticatorBase  -  Failed authenticate()
test ??/ulc/db/j_security_check
[30 Jun 2006 02:38:42,051] 106530 [http-8080-Processor23] DEBUG
org.apache.catalina.authenticator.AuthenticatorBase  - Security checking
request
GET /ulc/db/Navigate

-------------------------------------------------
This mail sent through IMP: www.resolution.com

---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message