tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bill Barker" <wbar...@wilshire.com>
Subject Re: Enabling https with a IBM JVM
Date Thu, 03 Aug 2006 03:46:00 GMT

"William Chu" <willchu@gmail.com> wrote in message 
news:587f280f0608022025o21e3cd43ub3586fc38665e511@mail.gmail.com...
> Hello,
>
> I am trying to enable https on Tomcat 3.3.1. I am using an IBM JVM.
> When I go to the url https://<ipaddr>, I see the following exception.
> In my browser, I get a 503 message saying that the "Server is
> starting".
>
> org.apache.tomcat.core.TomcatException: Root cause - Class
> com.ibm.jsse.bt configured for SSLContext not a SSLContext
>
> Do you have an idea why I can't access my page and get the above 
> exception?
>

I believe (although it has been a long time :) that 3.3.1 only works with 
Sun's JSSE (and v1.0 at that :).  However, you would certainly need to 
include algorithm="IbmX509" for it to have any chance of working.

TC 3.3.2 using the CoyoteConnector should work fine on an IBM JVM.

> Thank you very much for the help,
>
> Will
>
> ---------------------------------------------------------------------
> To start a new topic, e-mail: users@tomcat.apache.org
> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
> For additional commands, e-mail: users-help@tomcat.apache.org
>
> 




---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message