tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "kanderson" <kander...@trakit-gps.com>
Subject Tomcat 5.0.28 Error launching Tomcat Object heap size
Date Fri, 18 Aug 2006 15:46:06 GMT
We have been running Tomcat for awhile now and we had been running at
1024mb for the VM with a 256mb perm size and everything had been running
great.  Recently we tired to restart Tomcat and we started getting these
errors with initializing the VM. Normally we restart Tomcat about once
per week.

-JNI Error occurred during initialization of VM
-JNI Could not reserve enough space for object heap

Which makes it sound like all of the sudden we no longer have enough
memory for Tomcat to have 1024mb.  We were able to get it running about
by cutting down what Tomcat was using to 512mb and taking out the perm
size options. But with running this low on memory we get out of memory
with Tomcat very frequently which isn't really a shocker seeing how we
cut the memory we are using in half.  We are running on Windows 2003
server have 4 GB of ram.  I am running out of ideas on what could
possibly be the problem.  We have tried increasing the page file size on
the machine, tried the /3gb switch in the boot.ini, lowering thread
counts that are initially created with tomcat, removing contexts from
Tomcat, tried changing the stack size that each thread reserves, tried
reinstalling jdk 1.4.2, but we still haven't really been able to get our
server back up to the memory usage it was at before.

Also there have been a couple of weird things that have happened such as
one of the times we rebooted the actual machine tomcat came back up with
running at 1024mb and everything seemed to be ok but we tried restarting
the tomcat server again and it came up with the JNI error again.

As far as I know nothing had been changed in the Tomcat configuration
since the last time we rebooted so I don't really understand why all of
the sudden it would just stop working.  It almost seems to me like we
have bad ram or something.  The only other things I can think of trying
is to try reinstalling Tomcat or installing Tomcat on our spare server.

Any help would be appreciated
Thanks
Kyle

---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message