tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Filip Hanik - Dev Lists <devli...@hanik.com>
Subject Re: JK 1.2.18 win32 dll not working
Date Fri, 25 Aug 2006 17:36:56 GMT
its a known bug, the developers are pushing for 1.2.19 to get released

Filip


Jessica wrote:
> Hi Julie,
> I`m facing exactly the same problem as you described.
> Have you found any solution yet?
>
> Has anyone else succeded in getting jk-1.2.18 to run under IIS? 
> An answer would help in isolating the problem to IIS or JK.
> When googling for IIS isapi filters I came across this link:
> http://blogs.msdn.com/david.wang/archive/2005/06/21/HOWTO_Diagnose_and_Fix_Common_ISAPI_Filter_Installation_Failures.aspx
>
> which basicly tell us that the error code means that the ISAPI Filter
> specified an ISAPI Filter DLL that does not exist.
> But if for any reason GetFilterVersion(), HttpFilterProc() or
> GetFilterVersion() returns FALSE when IIS tries loadLibrary, then you will
> get the same error with WHATEVER value GetLastError() returns.
>
> Any help preciated!
> /* Jessica
>
>
>
> Julie Szmyd wrote:
>   
>> Hi,
>>
>> I tried to upgrade an older version of the win32 JK isapi_redirect.dll 
>> to the jk-1.2.18 version that I downloaded from 
>> http://mirrors.ibiblio.org/pub/mirrors/apache/tomcat/tomcat-connectors/jk/binaries/win32/jk-1.2.18.

>> For some reason, IIS is not able to load the ISAPI filter.  It errors 
>> out with the following message when I start IIS:
>>
>> ---------------------
>>
>> The HTTP Filter DLL C:\java\Tomcat\Jakarta Isapi 
>> Redirector\bin\isapi_redirect.dll failed to load.  The data is the error.
>>
>> data in bytes: 0000: 02 00 00 00               ....
>>
>> ---------------------
>>
>> I was able to successfully upgrade to the jk-1.2.15 version, which makes 
>> me think my setup is correct, and there could be  a problem with the 
>> binary for jk-1.2.18.  Has anyone else gotten the 1.2.18 version working 
>> on Windows XP IIS version 5.1?  Are there any differences in 
>> configuration from 1.2.15 to 1.2.18?
>>
>> Thanks,
>> Julie Szmyd
>>
>>
>>
>> ---------------------------------------------------------------------
>> To start a new topic, e-mail: users@tomcat.apache.org
>> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
>> For additional commands, e-mail: users-help@tomcat.apache.org
>>
>>
>>
>>     
>
>   


---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message